appointments+ not syncing with google cal

i have had appointments+ for some time now and i have not really used the sync on google cal into this year and am now finding out that they are not working like they should. website to google works fine but google to website not so good. there is a 5 min delay for it to make it to the website but it only stays in reserved by gcal and does not block out time and does not allow any info for that to be entered on the back end. Is this Just the way this works or do i have a problem.

thanks jason

  • James Morris

    Hello Jason,

    I hope you are well today.

    If you click the Information icon on the Appointments page, it gives a little better explanation of how the GCal sync feature works with the Appointments+ Plugin.

    Reserved by GCal: If you import appointments from Google Calender using Google Calendar API, that is, synchronize your calendar with Appointments+, events in your Google Calendar will be regarded as appointments and they will be shown here. These records cannot be edited here. Use your Google Calendar instead. They will be automatically updated in A+ too.

    As you can see by my test site, the GCal reserved times are blocked out so that no appointments can be set.

    Basically, how the sync works is, when an appointment is set in A+, the software does a push update to GCal. However, when an appointment is reserved in GCal, cron has to be used to check for new reservations. The reason this is not instantaneous is because there's not a persistent connection between GCal and A+. Such a connection would put too much stress on the Google API. So, cron is used to check periodically for new reservations.

    If you wish to update this faster, you can always perform a manual update by going to WP Admin -> Appointments -> Settings -> Google Calendar Tab -> Click Import and Update Events from GCal.

    If after doing this, the times reserved in GCal are still not blocked off and showing in the WP Admin -> Appointments -> Reserved by GCal section, then there is likely a communication issue and you will want to double-check your API settings for proper communication.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris