Appointments Plugin

I am having issues with the Appointments+ plugin. It doesn't seem to be working and I can't troubleshoot the figure out the cause. Are there any known plugin conflicts for this plugin and if not, is the most recent version compatible with Wordpress 3.5?