appointments+ plugin, mail is not sending

I resolved some issues with the plugin with short code, and it worked like a charm. All of a sudden, no mail reaches me or the client, I tried to deactivate, uninstall, install the plugin again, deactivating plugins that I used after the functioning mail, but nothing works, still no mail! What shall I do? I have Autoconfirm set to YES. One thing I was doing in between was changing the login options to just be Wordpress, not Facebook, et.c in the .js file, I figured that could have done some damage, so I reversed what I had deleted, did not work, then I reinstalled the plugin once more, does not work.

  • Elliott Bristow

    Hi @StudioTP,

    Welcome to the forums!

    Am I right in saying that you had this working and the emails WERE being sent out, and now they're not?

    Is the plugin working correctly otherwise, or are there any errors etc being reported? Are appointments being booked and handled correctly save for the emails being sent out?

    Have you checked the server's error log to see if there are any errors being reported when the plugin is trying to send our mails?

    When you say you changed a .js file then changed it back, which file did you change? And are you 100% sure the changes have been reverted?

    I know that's a lot of questions, but I'd rather cover as many bases at once as I can so that we can pinpoint the issue quickly.

    Also, it might be helpful to have a URL we can see so that we can check for any errors etc that might be affecting the plugin.

  • StudioTP

    Emails were sending out, Otherwise the plugin seems to work, It books the meetings and they show in the backend (wp-dashboard) I know the js file is reverted as I took everything away (deactivated the plugin) checked via ftp that all was in fact gone, and then reinstalled the plugin again, loosing all the settings, reset everything, but not working again.

    the js file was: appointments/js/appointments/api.js

    There is one odd thing, although I test with different users to book an appointment, with different mail adresses, the phonenumber that I wrote as one user, hangs on when I change user (CLIENT) And sometimes even the note that I wrote can stick there. although the note field isn't a required one.

    The URL to the booking is http://www.brocare.se/boka-2

    When I look into the php admin, sent and sent_worker says NULL on every row, I can't see any error messages (and don't really know were to look for it)

  • pxwm

    Hi,

    I've tried your link and selected a service and date but when I try and select a time is doesn't present me with the booking form.

    As for the form being pre-populated when you try and make a further appointment even though you have logged in as a different user I suspect this may be your browser cache.

    Try using a different browser for each user when you are testing or clear your browser cache or go into private browsing/incognito.

    Can you confirm that after making an appointment you get a message confirming the appointment has been successful received?

    If you do have you checked in the backend that the appointment is in 'confirmed' status.

    Are you using the latest version v1.2.8?

    If you are you can set email logs so you should be able to check these to at least check if the plug-in is sending the confirmation email.

    Assuming you have set the reminder emails could you confirm if these are being sent.

    Hope this helps
    Regards
    SteveB

  • StudioTP

    Trying other browsers helped for that issue. But the mail does not work.

    I use v1.2.8, "Send Reminder email to the Client" is the only setting with NO, and I should have gotten a couple of reminders to the Provider yesterday.

    I get a popup telling me that my booking is received, after the completion.

    The backend shows the booking. I just now tried to resend the confirmation by choosing that option in the dashboard and then press save/update, I get the following message in red inside the dashboard, tried hit save/update again, same thing...

    "Record could not be saved OR you did not make any changes!"

    I have had the "Log sent email records" active all the time, records must be gone after de deactivating and uninstall off course, but after the last install, there should be some records, where can I find the log?

    My issue still unresolved, I am sad to say. No mails received!

  • StudioTP

    I contacted my web hotel through mail support, have not received any respons from them, BUT I suddenly got things working again, the only thing I did was installing a plugin for SMTP, tried it, it didn't work. deactivated it and deleted it Then I changed email address for one of my users, then it started working properly ???? Haven't got a clue why! Gonna keep testing today and see if it keeps together. Gonna keep you posted.

  • pxwm

    Hi,

    Could you expand on 'Haven't done anything but change rows in notification emails'.

    Also you can view whether A+ is actually sending the email notification by selecting the 'Logs' tab and hopefully you will be able to view the email records when it was working and then confirm if A+ is still sending them.

    If it is then I suggest it is not a problem with A+ but your email account/email client.

    If you could confirm the above and hopefully this will enable us to pin down the problem.

    Regards
    SteveB

  • pxwm

    Hi,

    I've checked all your settings and I assume you have integrated BuddyPress, is that correct?

    I couldn't find 'Payment required'. Could you please confirm if this is set to 'Yes' or 'No'

    If it is set to 'Yes' could you set to 'No' and try making an appointment to test email confirmation.

    If it is set to 'No' you may wish to try these in order:-

    Number of appointment records per page - change from 0 to 10

    Login required - set to 'No'

    Accept login from front end - uncheck box

    Please let me know the outcomes.

    Regards
    SteveB

  • StudioTP

    No Buddypress.
    Payment required is set to No
    I tested all the configs, no result

    Changed to No payment, Login required, Accept login from front end checked

    I get a error message like this for Google+
    [Appointments+] Either php curl is not installed or HTTPS wrappers are not enabled. Login with Google+ will not work. Dismiss

    Log says none off the last mails has been sent, mail 24-32 (this morning I sent mail 1-23 and deleted a lot of the bookings, all this is in the log.

  • pxwm

    Hi,

    Many thanks for the feedback.

    You state in an earlier post that you are using v1.2.8 but you appear to have settings in the 'General' tab I don't have.

    That is: 'Accept login from the front end' and 'My Website already uses facebook'.

    Could you confirm if you are using any other plugins and if so could you list them all?

    *** Before you try the following you may want to take a full backup of your website and a database backup

    If you can you may wish to deactivate all your plug-ins except A+ then test.

    If this doesn't work then keep the other plug-ins deactivated and then deactivate and reactivate the A+ plug-in.

    With the other plugins deactivated could you try one more time setting: Required payment to 'No', Login required to 'No', Accept login from front end to 'unchecked'

    Regards
    SteveB

  • StudioTP

    I did all the steps you mention, and activated all again, tried with no login, and login required, It did not work! This is a real monster-assignment!

    see my plugins in the attached snapshot.

    I am soon gonna try deactivating and delete the plugin again, then maybe I will get it to work again, then gonna try and do booking after booking and see if it holds together or brakes without me doing anything else.

  • pxwm

    Hi,

    Apologies I've just found why the following fields are not visible to me:-

    'Accept login from the front end' and 'My Website already uses facebook'.

    It is because I have 'Login required' set to 'No'

    If I set them to 'Yes' then the fields are visible.

    As you state that you have set this field to 'No' and the problem still exists so I think we will move on from this.

    If you haven't already done so could you deactivate ALL plug-ins and then just activate A+ and then make an appointment

    If the problem still exists could you confirm if you have added any bespoke code to functions.php or changed the core plug-in code?

    If you haven't could you try reverting to the default theme and make an appointment.

    Regards
    SteveB

  • pxwm

    Hi,

    Just had a thought.

    Reviewing your earlier posts you stated the following:-

    Then I changed email address for one of my users, then it started working properly ???? Haven't got a clue why! Gonna keep testing today and see if it keeps together.

    Could you please confirm the original email address and the one you changed it to?

    You then state in a follow up post that it has started failing again.
    Could you confirm if you changed your email address back again?

    Also in your original post you state that you changed a js file and it failed and then you restored.

    Was this a js file within the A+ plug-in

    Just one last thing - Have you checked all the Wordpress user settings to ensure they are all valid and especially the emails are correct?

    Regards
    SteveB

  • StudioTP

    I changed it to my gmail address from one of my domain addresses at studiotp.se

    I did not change the address back.

    Don't know if the js failed, but I took away li for other logins than wordpress, because I only want that to be abled, and no back end for the customers, so I had to use the being able to login from the front end. js-file was within A+ called appointments/js/appointments/api.js this worked I only got wordpress to show up front end, and everything worked at least 1,5 hours after the update of the js-file

    All email, with one exception has at some point worked with the plugin, the exception being a fake one, with no catch-all on that address.

  • StudioTP

    This night/morning I took down the whole site, did a new install of the wordpress, installed Catalyst Theme framework, child theme and the plugin A+, configured, tested, It did not work!!! Then I tried a contact form on the site, does not work either, so something must happen with the php mail.

    There have been a developer that made a booking plugin for the site earlier, I saw in php this morning that there was still databases from his plugin, which I since long deactivated and deleted, maybe that caused the problem? I deleted these databases.

    I then tried to install and use an SMTP plugin, that returned an ERROR-message.

    We have tried so many things, and it makes no sense that a plugin should work On or Off, and another one (the contact form) also works on or off!

    Now I've asked the webhost if they can reset everything so I can start setting up the site again!! This time from real scratch, so I can test the A+ booking first, even before I use the framework and child theme.

    I will talk to my client, they were not happy with the mail function or support of their web host, so they were talking about changing their web hotel.

  • pxwm

    Hi,

    Is it possible you could check the version you are using for the following

    Wordpress
    PHP
    MySQL

    They need to be

    Wordpress - 3.5.1,
    PHP - 2.5.4 or greater
    MySQL - 5 or greater

    If these are okay could you install Wordpress and keep the theme as the default and then install A+.

    Then could you check the version of JQuery as I read in another post that there can be problems if you are using JQuery greater than 1.8.3.

    The version of JQuery can be changed if you upload a theme so can you just use the default theme to carry out your testing.

    With the versions checked, Wordpress installed using the default theme and A+ installed could you then make some tests.

    Out of interest you mention web hotel - is this a hosting provider?

    Regards
    SteveB

  • StudioTP

    I continued installing the Catalyst Theme Framework, it worked fine, Dynamik Childtheme from Catalyst, no problem, But when I tried to use some backup files from the previous install, it malfunctioned. So there is the problem I guess, changes made by the previous web developer gets everything to malfunction.

    Pity I don't know exactly what, it is some hours put down in this project now, a drag to have to almost start all over again!

    Thanks for all your help in solving this, much appreciated. /Tord

  • StudioTP

    Hi again, we cheered too early I'm afraid.

    Yesterday even with the default wptheme twenty twelve it stopped working, so I thought I have to find another plugin or booking system, but I had to get their site up and running anyway, so I did that, and I did not use anything that could have been changed by the previous developer. I then had an idea, I tried the plugin on my own site, with the exact same settings, so I configured A+ and "voila" it worked! I scrubbed my head! What was doing this?

    Well I continued with http://www.brocare.se and was thinking to hand over the site without the A+, but thought I could at least try it again, so I installed and activated the plugin and tried it again, it worked. I tested several bookings with different users, both yesterday and this morning It still worked.

    I continued with small changes to http://www.brocare.se and also installed a plugin called WP Social Ring, and Easy Contact Form (same as I have on the other site) All of a sudden after about two hours the mail does not send anymore. I try different settings, try again but nothing happens. Check the log it says nothings being sent anymore.

    I went in to the other site were I tested the plugin, to my astonishment it had stopped working there as well!! I had not changed anything on that site.

    So, to work out the common denominators of this, its the same A+ plugin, both sites are setup at One.com web hosting, They were made by me, I used the same computer, they both have Easy Contact form ( which also stopped working at the same time on both sites.)

    I tested to use another computer to make bookings, t did not work.

    So now where down to - A+ might not be compatible with something.
    - Something is happening at the web hostings with the mail function.

    Can a plugin stop after a couple of hours, and why could that be?

  • pxwm

    Hi Elliot,

    Just out of interest are you using the same hosting provider on both sites that fail?

    If you are, are they on the same shared server?

    If they are I am more than happy to offer you temporary hosting on our server if you want to test independent of your current hosting.

    This would be the same server we have A+ installed on a web site so I know the email notification works.

    Not sure if there is a way on this forum to use PM so you could send contact details without posting on the open forum.

    Just out of interest where are you located?

    Regards
    SteveB

  • StudioTP

    Tord not Elliot.

    Hi Steve

    we use the same hosting provider on both (so thats one of the common den.)

    I am located in Sweden, one.com my hosting is in Denmark, it is a low budget hosting but it has worked well, they have had some trouble with servers a couple of weeks ago, and they upgraded something. So maybe somethings wrong there.

    It would really be good to have the possibility to test on another server host.

    you could use the address support@studiotp.se if you like to contact me directly with details.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.