Appointments plugin not working as usual after recent update

Hi there,

After a recent update, my shortcodes have stopped working. I used to have following:

[app_services select=”Select appointment type & Location” autorefresh=”1″]

[app_service_providers select=”You will meet” require_service=”1″ autorefresh=”1″]

[app_monthly_schedule require_provider=”1″]

[app_pagination month=”1″]

[app_confirmation confirm_text=”Your appointment is approved automatically. In case we need to make a change, we will contact you asap. Thanks!”]

[app_paypal]

After the recent update, it is broken. I can also no longer see which shortcodes to use in the settings tab, there is no longer a shortcodes tab for reference.

https://www.dropbox.com/s/ev837c95uuqxzgo/Screenshot%202017-03-21%2016.55.56.png?dl=0

Please help.

  • James Morris
    • WordPress Enthusiast

    Hello Malkiat,

    I hope you are well today.

    The shortcodes have been moved into the WordPress Editor. Please see the following screenshots: https://goo.gl/p0rcqW and https://goo.gl/Ix0ikQ

    In order to further diagnose what is going on with your site, I would need to access your site to see better what is going on.

    In order to help you better with your issue, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please reply back here once you’ve enabled access so I will be notified.

    Best regards,

    James Morris

  • Luís
    • Support

    Hi Malkiat ,

    Hope you’re doing well today!

    I’ve confirmed this bug, it’s related to the parameter/attribute “require_provider=”1″” used in the “app_monthly_schedule” shortcode.

    I flagged the developer so they can get it fixed up asap. Either myself or the developer will reply back here once we have pushed a fix out.

    Cheers, Luís

  • Panos
    • SLS

    Hi Malkiat ,

    Sorry to hear you are having issues with Appointments +

    I was able to replicate this issue. Could you replace file:

    wp-content/plugins/appointments/includes/shortcodes/class-app-shortcode-service-providers.php

    with the one attached here and let us know if this works for you?

    Thanks!

  • Malkiat
    • Site Builder, Child of Zeus

    I have now created a new appointments page using “create a appointments page” for 1 months setting in the settings page and this seems to work (even though, the behaviour is different that what I had), now I am wondering if the replaced files are ok or do I need to go back to the ones before.

  • Panos
    • SLS

    Hi Malkiat ,

    even though, the behaviour is different that what I had

    Could you please provide more information about what is the behavior?

    There have been some improvements during past weeks on A+ files regarding these shortcodes. Until next release is out I have attached an unofficial version here which you can use instead.

    Download zip to your desktop.

    Before you upload, deactivate your current version, so you can keep it as a backup

    Then via ftp rename the current appointments folder to something else, adding a simple underscore would do, eg. _appointments, or appointments_backup

    Also rename the appointments.php file to appointments.php.txt

    Then go to your admin > Plugins and install the plugin zip you downloaded

    Now you can activate new plugin and see if this is still happening for you and let us know.

    PS

    I also just noticed that you mentioned

    I can also no longer see which shortcodes to use in the settings tab, there is no longer a shortcodes tab for reference.

    This has been changed, and a dropdown with shortcodes should be available in your pages editor.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.