Appointments+ plugin not working correctly

Today I installed appointments+ on my personal website. It is not working for me.

Check it yourself at the following link –

http://amargautam.com/make-an-appointment/

  • Hakan
    • The Incredible Smush

    That is indeed a problem.

    I am attaching a screenshot showing the javascript errors. Note especially the twitter error and the last one:

    XMLHttpRequest cannot load http://amarmainsite.pagemakr.com/wp-admin/admin-ajax.php. Origin http://amargautam.com is not allowed by Access-Control-Allow-Origin.

    So browser does not allow this setting.

    This is not something that I can fix.

    You should change the admin_url as http://amargautam.com/ or made it changed.

    Any plugin using ajaxurl will not work either.

    Cheers,

    Hakan

  • Amar Gautam
    • Flash Drive

    By the way, I experimented by deactivating all plugins and then reactivating one by one. I found the plugin that was the culprit.

    The admin url is not the problem. Twitter is not the problem as well.

    The problem is with the Social Marketing plugin. Now the social marketing plugin is deactivated and every thing is working fine.

    We need to fix the JS conflict between social marketing and appointments plugin. Please look into this matter ASAP.

    I am marking this as resolved but I am going to start a new thread about the conflict of JS among the two plugins.

    Thanks Hakan for your support.

  • Hakan
    • The Incredible Smush

    Hi,

    I cannot reproduce a conflict on my server.

    As you deactivated Social Marketing, twitter error is disappeared. SM is conflicting with another script (the Twitter widget) you are using, not with A+. Please note that some javascript errors prevent execution of the rest of the scripts on the same page.

    Try using SM using Twitter script off.

    To do so, Select Social Marketing>Settings and under Javascript box, select Yes for Twitter (My site already uses javascript from this service).

    Also you still have an error coming from the Twitter widget you are using. Please see attached screenshot. In fact you should fix that first. If the above solution does not work, you should remove the widget.

    Admin url is also important. If you switch to the earlier setting, plugin will not function correctly at least in Chrome and in Safari. You can see this from the first screenshot I added here.

    Cheers,

    Hakan

  • Tom Eagles
    • Syntax Hero

    Hiya, just going through some of the older threads here.

    As it’s been a little while since we last heard from you I thought I’d check in to see how you’re going?

    If you’re still looking for some further assistance with this thread then please feel free to reopen the thread or of course for any new and related issues you are most welcome to open a new thread.

    Cheers!

    Tom

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.