Appointments+ plugin: White screen after saving settings

Hi,
when I add some settings (no matter where) and press save I get a white screen with a warning: Warning: Cannot modify header information - headers already sent by (output started at /Applications/MAMP/htdocs/wordpress/wp-content/plugins/appointments/includes/widgets.php:41) in /Applications/MAMP/htdocs/wordpress/wp-includes/pluggable.php on line 1167

How can this be solved?

Best regards,
Sebastian

  • Rupok

    Hi Sebastian, hope you had a wonderful day.

    Can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If you have any MU Plugins installed, can you temporarily remove them too? Can you also try activating any default WordPress theme and check if the issue is still there? If not, then your currently active theme could be conflicting.

    Please let us know the result. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Sebastian

    Thanks for the reply.

    I don't have MU plugins installed, and even if I deactivate other plugins I still get the error.

    I also receive other messages in debug mode:
    Deprecated: Methods with the same name as their class as their class will not be constructors in a future version of PHP; Appointments_Widget_Services has a deprecated constructor in /Applications/MAMP/htdocs/wordpress/wp-content/plugins/appointments/includes/widgets.php on line 41

    When do you have the next release with bug fixes?

    Cheers,
    Sebastian

  • Nithin

    Hi Sebastian,

    Hope you are doing good today. :slight_smile:

    Could you please make sure to perform plugin conflict test, with a default theme enabled, and check whether it makes a difference.

    Header Already sent error appears when there is an extra white space in your files, this could happen when you have edited your files, or it could be some extra white space in your wp-config.php file. Please check this link for more info about troubleshooting this: https://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    When do you have the next release with bug fixes?

    Unfortunately we don't have an exact ETA on when a new release would be made available, developers will release an update once they troubleshoot all the necessary fixes, for the plugin. I'm afraid, I don't have an exact date at this moment.

    The deprecated messages are more of a log notices, and it doesn't tend to break your system, or the plugins functionality.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.