appointments plus and specific dates

To whom it may concern

My service only runs one day a month. So I selected no for all the days of the week and then added the specific date in exceptions but it doesn't seem to of worked. Please can you let me know why

kind regards

Peter

  • Milan
    • WordPress Wizard

    Hello Peter

    Hope you are well today and thanks for asking us. :slight_smile:

    I tested this one my sandbox site and it seems to be working well. Please take a look at these screenshots for confirmation. :slight_smile:

    May I take a look at your site's setup ? For that I'll need staff access to your site which you can grant me via WPMU DEV > Support > Support Access > Grant Access. Take a look at this screenshot.

    Looking forward to hearing back. :slight_smile:
    Cheers,
    Milan

  • Milan
    • WordPress Wizard

    Hello Peter

    Thanks for granting me staff access. :slight_smile:

    I just checked your site. I was not able to replicate issue there too. Everything is functioning the way it should function. Please take a look at these screenshots.

    Let me know if you are still facing issue. :slight_smile:
    Cheers,
    Milan

  • Dimitris
    • Support Star

    Hey there Peter,

    hope everything's really well for you and don't mind skipping in! :slight_smile:

    I believe the most convenient way to create a page with a full functional A+ form is through Appointments -> Settings -> General -> Display -> Create an Appointment Page

    By that, you'll get a new page called "Make an Appointment" which will have in place all of those shortcodes needed by A+. You don't have to use that page, but you can certainly copy/paste it's content. :wink:

    Is there a shortcode that will show availability for a specific service ?

    The [app_services] shortcode has couple of arguments (you may find them in yoursite.com/wp-admin/admin.php?page=app_shortcodes):

    show
    Button text to show the results for the selected. Default: "Show available times"
    Example: [app_services ... show="Show available times"]
    
    worker
    In some cases, you may want to display services which are given only by a certain provider. In that case enter provider ID here. Default: "0" (all defined services). Note: Multiple selections are not allowed.
    Example: [app_services ... worker="12"]

    Hope that was some kind of help,
    Dimitris :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.