Appointments+ removes copy on most of my website pages

When I activate Appointments+, the copy from most of my web pages disappear and only the title is left. Deactivate Appointments+ and it's fine. I've been running this plugin for 2+ years with this same theme and they were always fine. I have not added any other plugins besides WPMUDEV plugs in (wp-smush, smartcrawl, hummingbird). I'm not sure when it stopped working, I wasn't informed until today.

  • Rupok

    Hi Michael

    Hope you had a wonderful day.

    When I activate Appointments+, the copy from most of my web pages disappear and only the title is left

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. So I tried to login with Support Access, but it's showing me the following error:
    Sorry, this is an invalid access token. You must ask the user to grant access.
    It happens sometimes. Can you please revoke and grant us permission again so we can have a closer look at this and try to resolve this as soon as possible?

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Michael

    Hope you had a wonderful day.

    Thanks for granting Support Access again. I logged in, tried to confirm the issue on your site and I could see the issue in action. But this is really strange, I tried to regenerate this on my test site but I could not.

    Can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, please paste them to a text file and attach with your reply.

    Have a nice day. Cheers!
    Rupok

  • Michael

    Hello Rupok,
    Thank you for the excellent instructions. I did not find a debug.log file but I did find an error.log that's been there for years. I think this is the info you need from that:

    [26-Mar-2016 08:56:58 UTC] PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home3/rafflet1/public_html/thepaperie/wp-content/plugins/backupbuddy/classes/core.php on line 3241
    [26-Mar-2016 16:41:20 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'Appointments' does not have a method 'post_ceontent' in /home3/rafflet1/public_html/thepaperie/wp-includes/plugin.php on line 235
    [26-Mar-2016 16:41:43 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'Appointments' does not have a method 'post_ceontent' in /home3/rafflet1/public_html/thepaperie/wp-includes/plugin.php on line 235

    The debug code is still in the wp-config.php file, should I remove it?

  • Kasia Swiderska

    Hello Michael,

    It looks like this issue is caused by the known bug in Appointments+ - please follow these instructions here https://premium.wpmudev.org/forums/topic/breaking-stuff-with-multiple-errors#post-1050495 - it will fix this error.

    It will be included in the future release of the plugin so after next update you will not need to apply this again.

    The debug code is still in the wp-config.php file, should I remove it?

    After you apply patch for this bug you can remove this code.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.