Appointments + setting service-specific timeframes

I am having two issues with my appointments.

1st issue:
I just need "Half Day Mediation - Morning" service to start at 9:00 am and not be available in the afternoon, and "Half Day Mediation - Afternoon" service to start at 1:30 pm and not be available in the morning.

2nd issue :
When you go to select a service, and then if you click a different month, the page refreshes and the service you selected reverts back to the first in the list.

  • Predrag Dubajic

    Hey tkorlando,

    Hope you're doing well today :slight_smile:

    I had a look at your settings and I'm afraid that with current setup this will not be possible and you will need to make some adjustments to get #1 working as intended.

    First thing to note is that working hours are tied to Workers and not Services so in order to have different working times you will need to have one worked for morning shift and for afternoon.
    You can use Dummy provider for this as well.

    There are some other stuff that need to be changed in your current setup.
    First one is to change Time Base in Appointments > Settings to 30 minutes, this will allow you to book an appointment at 1:30PM.

    When you set this up next thing is to go to Working Hours and set them to from 8AM to 5:30PM, your current time is from 12AM - 12AM because of your Time Base setting.
    NOTE: This is for your current setup, when you create new Workers in order to have Morning and Afternoon shifts you will need to adjust working times accordingly.

    Next, go to Addons and disable Paddings add-on, you won't need this, and instead activate Tetris mode.

    Now go to General > Advanced tab and in there disable overwork, this also won't be needed once Tetris mode is active.

    Save your settings and that should be it.

    2nd issue :
    When you go to select a service, and then if you click a different month, the page refreshes and the service you selected reverts back to the first in the list.

    I was unable to replicate this issue on my installation and it looks like it's caused by your page builder and how it handles shortcodes.
    Can you test this out without the builder and with default WP theme active to see if that's indeed the case?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.