Appointments + Setting Working Hours

Hi there,
I've set the Time base to 60 minutes. And the working hours Mon to Fri from 9 am to 5 pm.
The break hours from 11 am to 2 pm. Therefore a 3 pm slot should show up in the schedule but it doesn't. Any idea what I need to do to fix?
My web page is http://webdesigndigitalstudio.com/appointments/
Many thanks for your help, Tina

  • pxwm

    Hi Tina,

    I've checked your settings and could you try the following:-

    Login to your Wordpress dashboard as Admin
    Select A+ settings
    Select 'Working Hours' tab
    As you only have one service provider then select TinaCook from the dropdown and set as per your 'no specific provider' Working Hour settings.
    Once set then select 'no specific provider' from the dropdown and set all the 'Work?' tab to 'No'

    This should then work as required.

    However when you view your appointment page it may display the scheduler with the 'no specific provider' selected and if it does this will show no dates available and a visitor to the site would then have to select TinaCook from the dropdown.

    If this happens it may be a bit confusing to the visitor so you could try changing the following shortcode in your 'Appointment' page as shown below.

    Also as you only have one service you may wish to auto select this so you could try changing the following shortcode in your 'Appointment' page as shown below

    Also as you only have one service and service provider you may also wish to remove the 'Show available times and if so you could add change the following shortcode as shown below

    Login to the Wordpress dashboard as Admin
    Select 'Pages' in the left hand menu
    Select the 'Appointment' page
    In there you will see a set of shortcodes

    replace [app_service] with [app_service worker="1" autorefresh="1"]
    The "1" is the ID of TinaCook the service provider
    This will force the scheduler to be viewed for TinaCook
    This will also force the service 'Social Media Consultancy' to be selected as TinaCook is the only service provider assigned to this service
    The autorefresh will remove the 'Show available times' service dropdown

    Replace [app_service_providers] with [app_service_providers autorefresh="1"]
    The autorefresh will remove the 'Show available times' for the service provider dropdown

    Hope this helps
    Regards
    SteveB

  • TinaCook

    Hi Steve,
    Thanks for your suggestions. I did this part:

    Login to your Wordpress dashboard as Admin
    Select A+ settings
    Select 'Working Hours' tab
    As you only have one service provider then select TinaCook from the dropdown and set as per your 'no specific provider' Working Hour settings.
    Once set then select 'no specific provider' from the dropdown and set all the 'Work?' tab to 'No'

    But unfortunately it didn't fix the issue. Only Tina Cook is showing in the service provider. I do plan to have more services and providers.

    This is so strange as have use Appointments+ before without any problems. There must be a way to get the appointments to show up.

    With thanks, Tina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.