Appointments+ settings -> add a service

Just purchased the month full membership but have an issue with appointments plus.
In settings -> add service, your plug in message says: Here you should define your services for which your client will be making appointments. There must be at least one service defined. Capacity is the number of customers that can take the service at the same time. Enter 0 for no specific limit (Limited to number of service providers, or to 1 if no service provider is defined for that service). Price is only required if you request payment to accept appointments. You can define a description page for the service you are providing. When I click the link nothing happens.... therefore I cannot add a "NEW SERVICE" Please advise.

  • Vinod Dalvi
    • WP Unicorn

    Hi @deb,

    Sorry to hear of the problems you are having.

    when I click the link nothing happens.... therefore I cannot add a "NEW SERVICE" Please advise.

    I have tested it on my test site using latest version of Appointments + plugin and it worked fine allowing me to add new services.

    Have you clicked on any other link or "Add New Service" button to add new services as displayed in the attached screenshot?

    Kind Regards,
    Vinod Dalvi

  • deb
    • Site Builder, Child of Zeus

    Hi Vinod

    Thank you for the response. But when i click the button "add new service" nothing happens. I did enable quite a few add-on's, perhaps they have had a conflict?
    should i remove and reload? will this reset everything? I just tried again while writing to you and i still don't get anything show up. I am using WP 3.8.1.

  • deb
    • Site Builder, Child of Zeus

    Hi Vinod, I deactivated the appointment + program and activated it again (which loaded the same settings as previous) but I still have the same issue. I cannot add new services, I click the button but nothing happens. I have made a change to the default service, could that be the problem?

    I have attached a copy of the pages source code because there is nothing in the log file to send you. How do i activate log reports?

    Thank you again for all your help.
    regards Suzie

  • Vinod Dalvi
    • WP Unicorn

    Hi Suzie,

    Thank you for your detailed reply.

    I have attached a copy of the pages source code because there is nothing in the log file to send you. How do i activate log reports?

    I didn't find any attached copy of the page source code, i think you forgot to attach it.

    You will find Appointments+ log reports on the following path.

    Admin area -> Appointments -> Settings -> Logs tab

    You can also enable WordPress debugging by enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you'd like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting!

    I have made a change to the default service, could that be the problem?

    What changes and where have you made it?

    Have you made changes in the plugin file?

    If yes then please try reverting the changes.

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.