Appointments start time/duration

My client is offering start times for appointments every 30 minutes, however, the duration of the appointments varies from 30 to 120 minutes. Right now, if someone chooses a 120 appointment, then all the time slots change so there are only appointment times every two hours. If there are no other appointments, he'd like to offer to start new appointments every 30 minutes.

How do I accomplish that?

  • Adam Czajczyk

    Hey Amy,

    I hope you're well today and thank you for this question!

    Right "out of the box" I can think of two possible setups:

    1. Setting appointments available only in 30 minutes length and telling users that they can book for example 2 or more consecutive appointments.

    2. Setting multiple (might be dummy) providers that would be assigned to each type of appointment so before booking user would have to select provider (a.k.a the appointment length). With a little help of "Shared Resources" add-on it should be possible to create a setup like the one in question.

    To enable "Shared resources" add-on please go to your dashboard's

    "Appointments" -> "Settings" page -> "Add-ons" tab and scroll down a bit.

    I think this should point you in a right direction but if you need any further assistance with it, please let me know. It would be also great if you could in such a case grant me a support access to your dashboard so I could take a closer look.

    To do this, please follow this guide:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day!
    Adam

  • Amy

    Yes, please help me. I granted access.

    Here is what I need. We have several different services, each offered for 30, 60, 90, or 120 minutes. I want appointment times to be available every 30 minutes. If there are no other appointments, then they can book at whatever time they want.

    I set up "padding" after the appointments, but messes up the appointment start times too. We need 30 minutes after each appointment blocked off, but that doesn't mean we should only see one hour openings throughout the day.

    Does this make sense?

    I enabled shared resources but don't know where to go from here.

  • Adam Czajczyk

    Hey Amy,

    Thanks for the clarification on this. I think I get your point now.

    So when I go to the schedule and choose the service, I should see slots every 30 minutes starting at 8AM. But I don't. I only get one hour time slots starting at 8.

    Most likely this is because of padding. However to confirm this I'd need to take a closer look. I tried to access your site using a support access that you've granted but it seems that your site is also protected by some additional password tool. Therefore I'm not able to pass through it.

    That being said, I think we'll need a different approach here. Could you please create a temporary account on your site for me (with the full admin/super-admin credentials) and then send me all the information necessary to log in?

    To do this, please use our contact form here https://premium.wpmudev.org/contact/.

    Use this as a subject line: "ATTN: Adam Czajczyk" and include link back to this thread in the message.

    Be sure to select "I have a different question" from the drop-down list and make a full backup of your site first.

    Thanks,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.