Appointments+ Time Slots Showing Incorrect Times

I'm trying to set up a Provider working a specific day on the calendar within a specific time frame (Sunday, September 22, 2013, from 9 AM to 5 PM). I figured out that in order for this to work, you need to set the "No specific provider" to a "9 AM" Start time and a "5 PM" End time on the specific day of the week (Sunday) you want that specific date (2013-09-22) to fall on. You then set up that specific date "Exceptional working day" for that Provider.

This all works well until you go to choose a time slot to book the appointment. It shows times from 8 AM to 5:30 PM. I'm racking my brains trying to figure out the discrepancy. Any ideas?

Here's a link to the offending page: http://midwestrescue.org/make-an-appointment/

  • pxwm

    Hi @aristath - Hope you don't mind me chiming in

    Hi @Tread

    Assuming you have assigned all the 'Services' to the one specific Service Provider then I would suggest you try the following:-

    Set the 'Working Hours' for the 'no specific provider' to 'No'
    Select the specific Service Provider from the dropdown
    Set the required 'Working Hours' for the specific Service Provider.

    Then select the 'Exceptions' tab
    Then remove any exception rules from the 'no specific provider'
    Select the specific Service Provider from the dropdown
    Then set the required exceptions for the specific Service Provider.

    There may also be a problem with the way you have set the 'Time Base' and as @aristath has requested could you please provide/confirm the following:-

    A screenpost of your 'Time Settings' section in the 'General' tab
    The duration time for each of your Services.

    Regards
    SteveB

  • Tread

    @aristath,

    I tried posting screenshots last night and it wouldn't let me so I'll try again now. Edit: My screenshot uploads keep failing. I have a feeling it has to do with yesterday's outage. I tried on both Safari and on Firefox.

    @pxwm,

    Setting those hours for Provider allows people to choose those hours on multiple Sundays, not the specific date that I want, and that's even with the exception rule for set for the Provider. It does however, correct the time issue. If I set multiple Exceptional NON working days it will block out the other Sundays, but this is not an ideal solution. What that means is that there is a default set of hours somewhere set within the plugin.

    My Time Settings are as follows:

    Time base (minutes): 30
    Additional time base (minutes): blank
    Admin side time base (minutes): blank
    Appointments lower limit (hours): 0
    Appointments upper limit (days): 30
    Disable pending appointments after (mins): 60
    Minimum time to pass for new appointment (secs): 0

  • pxwm

    Hi @Tread

    Many thanks for your feedback.

    If I've understood your feedback then I'm assuming you've tried adding all the Non Working Sundays in the 'Exceptional NON working days, e.g. holidays: ' field in the 'Exceptions' tab as you have stated:-

    If I set multiple Exceptional NON working days it will block out the other Sundays, but this is not an ideal solution.

    I'm not sure there is any other solution.
    Out of interest why is blocking out the other Sundays not ideal?

    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.