Appointments timing out with my new SSL in older version of explorer

I got a SSL for my site. and after closing the plugging that where returning errors on why no padlock, The main company that uses it could not book an appointment with their older version of explorer.

I honestly do not know what is going on because the plugins that first caused errors are no longer causing errors and I can use the plugins again.

But even if I deactivate those plugins and change the theme, they still can not book.

What they tell me is that after clicking on a available time the wheel just keeps on spinning and the confirmation box never pops up.

Any ideas?
I have granted access!
thanks,
Matt