Appointment's username doesn't automatically fill in

In Appointments+ once a user has completed an appointment, if I go into the dashboard under, "Appointments" --> "Completed Appointments" and click "See Details & Edit", under the appointment information section for the appointment's Client Information "User" it says "Not registered user." All of my appointments require them to be logged in, so how can I get this to be automatically set to the user's actual username? This may be for the active & removed appointments also, but currently I only have a completed appointment.

  • Alexander
    • DEV MAN’s Mascot

    Hi @brascomarketing,

    I've just tested this, and with "Login Required" enabled (from Appointments+ settings) it is assigning the user to the appointment properly.

    Can you confirm that you have this setting enabled?

    Also, is it doing this for all bookings? Or just this one? Can you try a test booking to see if it's still occurring?

    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    Hi @brascomarketing,

    Would it be possible for you to use normal usernames?

    Appointments+ simply uses functions to interact with the built in WordPress users. I'm not sure why this would be affected, but is likely related to the other plugin modifying the WordPress user system. So I'm afraid Appointments+ isn't compatible with the changes.

    It might be possible to bridge the gap with some custom development, but I'm not sure how this would work.

    I will move this to Features & Feedback though so we can see what other community members think, and so it can be considered for future development. If you need to hire a developer, I'd strongly recommend checking our our job boards: https://premium.wpmudev.org/wordpress-development/

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.