Appointments+ working hours problem

Hello, I have the following issue
I have 2 shifts of 12 Hrs (720mins) each, each shift will start at 5:00am or 17:00 so one shift is from 5:00 to 17:00 and the other one from 17:00 to 5:00 next day.
The problem is that when i set the working hours from 5:00 to 5:00 the service appears busy, if i set the working hours from 00:00 to 00:00 both shifts of the service appears normaly.
It is crousial for the company to work the way i describe, can you please give me a solution?
Thank you.

  • Predrag Dubajic

    Hey Makis,

    Hope you're doing well today :slight_smile:

    I did some testing for this setup on my installation and I believe that I have a solution for you, try the steps below and tell me if that works for you.

    - In Appointments > Settings > General set base time to 60 minutes
    - Create two services with 720 minutes duration
    - Create two service providers, assign Provider1 to Service1 and Provider2 to Service2
    - Go to Appointments > Settings > Working Hours tab and in there for Provider1 set working hours from 05:00am to 05:00pm and for Provider2 set hours from 05:00pm to 12:00am
    For Provider2 make sure you select 12:00am that's last value in selector and not the first one.
    - Now go to Appointments > Settings > General tab again and scroll down to Allow Overwork (end of day) option and change it to YES

    After that your desired setup should work.

    Let us know how it goes and if you have any followup questions :slight_smile:

    Best regards,
    Predrag

  • Makis

    Hi Predrag, thank you for your instant response.
    The problem is still there because the second shift is from 5:00pm to 5:00am not from 5:00pm to 12am. Also i don't want to use providers.
    I have 16 services with 12 hours shift each, starting at 5:00 am so each service has 2 shifts of 12 hours 5:00am to 5:00pm and 5:00pm to 5:00am.
    Try to make an appointment from 5:00pm to 5:00am, works for you? For me it doesn't.
    I hope I explained better now .
    Thank you.

  • Adam Czajczyk

    Hello Makis,

    I hope you're well today!

    i think solution proposed by Predrag should work without service providers defined as well. I tested it on my own site and here's what I did exactly, based on Predrags advice:

    1. disabled the "Durations" add-on (that alters the way slots are calculated)
    2. removed all "service providers" (there's no service providers now on my sandbox)
    3. On "Appointments -> Settings" page I
    - set "Time base (minutes)" option to "60"
    - set "Allow Overwork (end of day)" and "Allow Overwork (break hours)" options to "YES"
    4. I created a few services lasting 720 minutes each
    5. On "Working hours" tab:
    - I disabled all "Break hours" (by setting "Give break" option to "No" for each day)
    - I turned on each day of the week by setting "Work?" option to "Yes"
    - I set "Start" hour to "5:00 am" and "End" hour to "12:00 am" for each day

    As you can see on an attached screenshot I'm not getting two appointments available a day starting respectively at 5:00 am and 5:00 pm, each lasting 12 hours.

    I think this should also work on your site if you follow closely the guide above. However, it's possible that some other add-on/setting that we're not aware of (I was testing this on a "clean" setup) are getting in a way. In case it didn't work for you, would you mind granting me a support access to your site so I could take a closer look? To do this please follow this guide:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.