Apps+ dummy provider shows disabled on edit page & no emails sent.

I’m not receiving any emails when bookings are made from appointments+. There’s a dummy provider assigned to my user account in the settings.

The strange thing is, on the Providers page it says the user is a dummy user, but when I click to edit the provider, it says they are not a dummy provider.

https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/a8f6d4e748f7c20246f495374d8c3a94/Screenshot%202019-04-02%20at%2018.20.35.png

Here’s the problem: on the screenshot above, you can see that user “Betty” is declared to be a dummy.

However, when I click on details, it says: dummy: NO.

https://cdn.livechat-static.com/api/file/v2/lc/att-old/8801096/785440977ed2c4460c9e71a510c62b38/Screenshot%202019-04-02%20at%2018.21.52.png

I’m confused about her status about being a dummy or not. Otherwise, if she were a dummy, the mails should have been sent to 24@++++++rees.be, which is me. But I haven’t received any mail either.

  • Michael
    • The Incredible Code Injector

    Hi all,

    I don’t know if this is related but I add it as extra info:

    the basic functionality that’s not working is that “Betty” is a service provider. But if someone who’s not “Betty” books a service she provides (and where she is the only service provider), she doesn’t receive any mails of it.

    Thanks all for your support !

  • Dimitris
    • Support Star

    Hello there Michael,

    hope you’re doing well! :slight_smile:

    I was able to replicate the issue with changing the “dummy” status of a user and I’ll create a bug report for our developers.

    I wasn’t able to replicate the issue with the emails though, as my admin user where still getting the confirmation emails even when I was having a single dummy user assigned to a service.

    Please keep in mind that the admin user email that’s going to be used in this case isn’t the email address of an admin user but the Email Address used to Settings -> General, which seems to be a different one for the mapped site.

    There’s a filter that you could use in order to edit the admin emails. For doing that, you should create a little MU plugin file, like wp-content/mu-plugins/app-admin-email.php

    (simply create the /mu-plugins/ folder if it doesn’t exist already)

    and insert the exact code in there:

    <?php
    add_filter( 'app_confirmation_disable_admin', function( $disable, $app, $app_id, $admin_email ) {

    $appointments = appointments();
    $receivers = array( 'one@test.com', 'two@test.com', 'three@test.com' );
    $notification_manager = new Appointments_Notifications_Manager();
    $confirmation_obj = new Appointments_Notifications_Confirmation( $notification_manager );

    $template = $confirmation_obj->get_admin_template( $app_id );

    if ( ! $template ) {
    return false;
    }

    $result = wp_mail(
    $receivers,
    $template['subject'],
    $template['body'],
    $appointments->message_headers()
    );

    if ( $result ) {
    do_action( 'appointments_confirmation_admin_sent', $admin_email, $app_id, $template['body'], $template['subject'] );
    }

    return true;
    }, 20, 4 );

    Then edit this line

    $receivers = array( 'one@test.com', 'two@test.com', 'three@test.com' );

    and insert the email address(es) you need for your admin user(s).

    Hope that was some help, let us know who that goes!

    Thank you,

    Dimitris

  • Dimitris
    • Support Star

    Hello there Michael,

    hope you’re doing well today!

    I’m using Gmail SMTP to send mails from this subsite. Shouldn’t I add an “Authorized redirect URIs” for Appointments+ for this site? Maybe it’s using a different redirect?

    You shouldn’t be needing a setting like this, emails should be working anyway.

    Since I have to use this code only for one subsite on my multisite, I’m currently creating a plugin for it. That way, I can activate it only for one subsite.

    That’s true, you’ll need either a normal plugin or a child theme and insert the snippet in the functions.php file of it (and then enable per-site of course).

    Only logged when trying to change the status of an “awaiting approval” appointment to status “Confirmed”.

    Can you please elaborate a bit more on this?

    Is this about another issue than the original reported one?

    Please advise!

    Thank you,

    Dimitris

  • Dimitris
    • Support Star

    Hello there Michael

    I can see in this other thread that the issue wasn’t that emails weren’t getting sent, as an SMTP plugin resolved that in our hosting which doesn’t support non-transactional emails.

    Are you still having a SMTP connection made to your website?

    If so, can you check email delivery in general? You can try with the “forgot password” email.

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.