Are all the plugins made to work only with your template?

I can’t use any other template? I’m using Betheme.