Are appointments+ and Google+ plugins compatiable?

I've been folding all the sites together and when I installed Appointments+ onto the XMFtech site this morning, it crashed the site and in the network admin section, the pages didn't return any data. A quick error log check and I see: [Fri Mar 08 19:50:01 2013] [error] [client ::1] PHP Fatal error: require_once(): Cannot redeclare class uri_template_parser in /var/www/html/wp-content/plugins/wpmu-dev-plusone/lib/external/google/io/apiREST.php on line 18

As soon as I removed the appointments + plugin, the error goes away and the site loads fine. Is this a conflict between the two plugins or something in my local configuration?