Are the Smush servers working?

For over 6 hours, the message displayed on my site's WP Smush Pro Admin page has been:
"The smushing elfs are busy, You are 2nd in queue.
Current wait time: 2.5 hours"

Despite refreshing the page, the wait time has not changed. All of the images have been sent for smushing; none of them have been fetched.

I just tried to individually Smush one image on a different site and received the message:
"Oh Snap! Seems like Smush Pro server is not reachable, you can try back in some time."

Are your Smush servers working? And if they are not, how do I cancel the bulk "smushing" that seems currently to be stalled?

  • Vinod Dalvi
    • WP Unicorn

    Hi Jeanne,

    Welcome to the WPMU Dev community and thanks for posting on the forum.

    I think the Smush server is working fine as the WP Smush Pro is working on my test site without any issue.

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi Jeanne,

    Thank you for granting us support staff access.

    I could confirm the issue on your site.

    Which hosting provider are you using?
    Are you using CloudFlare?

    Was it ever working for you?

    I can see you are using many security, cache and redirection plugin.

    If possible could you please just try temporary deactivating it as they may block the smush server connection.

    Regards,
    Vinod Dalvi

  • Jeanne
    • WPMU DEV Initiate

    Hi Vinod,

    I accessed Smush earlier today on a different site with no problem. Same hosting provider, same plug-ins so I doubt this is the issue.

    Yes, I use CloudFlare and the Smush server has been added to the "trusted" list per a support query I read on this forum.

    W3 Total Cache has not been activated on my site so it shouldn't be an issue.

    How can I terminate the "Smushing"?

  • Jeanne
    • WPMU DEV Initiate

    I disabled the security plug-ins and there's no difference in the "The smushing elfs are busy, You are 2nd in queue.
    Current wait time: 2.5 hours" message.

    If you have no other suggestions, please let me know the best way to terminate the smushing process - delete the plugin?

    Thanks.

  • Jack Kitterhing
    • Code Norris

    Hi there @Jeanne,

    Hope you're well today and thanks for your question.

    You can use this code to reset the smush status:

    delete_option('wp-smpro-sent-ids');
    delete_option('wp-smpro-bulk-sent');
    delete_option('wp-smpro-bulk-received');
    delete_option('wp-smpro-current-requests');
    delete_site_option('wp-smpro-current-requests');
    global $wpdb;
    $wpdb->query("DELETE FROM $wpdb->postmeta WHERE meta_key='wp-smpro-is-smushed' OR meta_key='wp-smpro-smush-data' OR meta_key LIKE '%wp-smpro-request%' ");

    You can either add that to a simple plugin, like at the end of "Hello Dolly" activate hello dolly and then it'll be reset, then deactivate hello dolly and re-send the request.

    Or you can add that in your functions.php (make sure to remove the code, before sending the request again, otherwise it'll just keep deleting the request).

    Has W3 Total cache ever been activated on the site at any point? If it has, it may be set to true in your wp-config.php and added code to your .htaccess file.

    Thanks!

    Kind Regards
    Jack.

  • Jeanne
    • WPMU DEV Initiate

    Hi Jack,

    Thank you for getting back to me with good information for the future. My earlier Smush request finally went through - when I checked on Jan 1, I found all the images had been smushed :slight_smile:

    The message window ("The smushing elfs are busy, You are 2nd in queue. Current wait time: 2.5 hours") seems to not update as the request moves forward - but the process ultimately worked. Yea!

    Best,

    Jeanne

  • Vinod Dalvi
    • WP Unicorn

    Hi Vastaffer,

    Sorry to hear of the problem you are having.

    Thanks for posting in this thread, however it might be best if you open your own https://premium.wpmudev.org/forums/#question , even if the issues seem closely related. That way it will remain independent of this one and ensure it doesn't confuse issues here if this thread needs reopening again by the author.

    It also means the member who started this thread or anyone following it isn't inundated with post notifications each time we respond to each other. A lengthy thread could annoy the original

    This also allows us to better track and answer your questions to ensure we don't miss any for ya.

    Thanks,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.