Are you sure you want to do that? – New Buddypress group creation

I have a multisite install with 5 sites running the newest version (4.6.1) and I've been having this problem since before upgrading to 4.6.

I have Buddypress installed on multiple sites and I'm using BP Multi Network to have a separate network on each site. On any of the sites (within the last 2 months) when I try to create a new Buddypress Group, I get the "Are you sure you want to do that?" error message. The group is still created, but I have to go back and finish the setup process to make it work.

The error message ALWAYS shows up, but not always on the same step. Sometimes it happens when choosing if the group will be public/private, other times it happens when I am should be able to enable forums. When the error is about to happen all other text except for the headline and the forward and back buttons is missing. See attachment.

What I've tried:

I disabled all plugins except for Buddypress and tried to create a new group: still got the error message.

With only Buddypress active I tried switching my theme to Twenty Sixteen: still got the error message.

The error happens across all sites in the multisite.

I'm hosting with Rackspace under this setup:

Load Balancer

2gb Server for Database

4gb Web server

4gb Slave Web server

I'm at a loss. One of my sites is a Dev site that is a clone of my main site so I have the ability to test without breaking everything (except when I disabled all plugins, that affected every site)

http://www.theholler.org is the main site

dev.theholler.org is the dev site

  • Adam Czajczyk
    • Support Gorilla

    Hello Bruce,

    I hope you’re well today and thank you for your question!

    The “Are you sure you want to do that?” question usually appears when WP is not able to verify the “nonce” that should be passed to it. This however can be caused buy a number of reasons and a plugin/theme conflict is one of the most often among them.

    However, since you already run a conflict test and it didn’t help let’s try something else here. I checked your site and I noticed that although the server allows up to 512M of memory to be used by PHP scripts your WordPress is still limited to 64M only. This may be causing unexpected issues in case of complex sites.

    That said, please make sure that following line is inside your site’s “wp-config.php” file:

    define(‘WP_MEMORY_LIMIT’,’512M’:wink:;

    This line should be located above the “/* That’s all, stop editing! */” line and will increase allowed memory limit for WordPress. Hopefully, this would fix the issue.

    In case it did not though, please re-upload fresh WP files to the site. To do this:

    – download fresh WP install package (zip archive)

    – extract it to your local drive

    – access your server via FTP

    – download all the files (make a full backup of all the files of your site); that step is extremely important!

    – remove all the files and folders along with their contents from your WP install (your site) root folder except the “wp-content” folder and its content and the “wp-config.php” file

    – upload all the files and folder there from that fresh WP install package, again – except the “wp-content” folder and its content and the “wp-config.php” file

    Once that’s done, please clear all the caches on the site and in your browser and check if the issue still occurs.

    Keep me informed on this, please!

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.