Asset Optimization breaking homepage video

Trying to tweak the Asset Optimization, and the youtube video in the homepage breaks. At the moment the combine feature is disabled, and the homepage seems to loads fine.

Looking to resolve this once combine option is enabled, and also need help in reducing render blocking issue, and to find the optimal setting. Please advise.

  • James Morris

    Hello victor

    I hope you are well today.

    Checking your chat transcript, I'm seeing you were having some issues with Asset Optimization. This is the most common sticking point for members because this is the most powerful feature of Hummingbird.

    Where Hummingbird is different than most optimization plugins is it gives you very granular control over which assets are optimized. The downsize of this is, if you don't take your time and go through the plugin carefully, you can break your site. This isn't an issue with Hummingbird so much as it is a limitation of CSS and JavaScript. Some assets just don't play well being minified, combined, deferred or relocated.

    We've put together an excellent guide in our Docs section that will walk you through, step-by-step on how to the the very best performance out of Hummingbird. Please see: https://premium.wpmudev.org/docs/wpmu-dev-plugins/hummingbird/

    It's very important to take your time and work through this process slowly. Asset Optimization is by far one of the most critical tasks in improving site speed. If you take your time and work through this carefully, you will be rewarded with significant gains in performance. But this is a process that must be taken one step at a time.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.