Asynch Appointments synch not working between Appointments+ and Gcal

HI, Hope someone can help me with this.

I setup the Link between Appointments+ and GCal. The tutorial in the plugin was quite outdated but I think I managed to navigate my way through the Gcal setup correctly.
Appointments that come through A+ do get added correctly into Gcal.

However, If I try and block out some time in Gcal, it does not reflect or affect anything in A+

My client needs to be able to manually enter appointments into her Gcal via her phone and not get double booked through the website.

In the Google Calendar Settings of A+ i am using the (A+ <-> GCal Synch) setting works in both directions.

Any help would be appreciated.

Regards

Ad

  • Denitsa
    • WordPress Warrior

    Hello Adeon,
    I hope you're having a beautiful day!

    Do you have any cache/cache plugin installed (if yes, disable it and try again)?

    What happens if you go to Appointments -> Settings -> Google Calendar and click on the Import and Update Events from GCal button at the bottom of the page?

    Looking forward to hearing back!

    Cheers,
    Denitsa

  • Adeon
    • Design Lord, Child of Thor

    Yey that worked!

    Thank You!

    So, can that be done automatically or does it have to be done all the time manually?

    I have a client with 15 service providers, so we need it updated every time someone tries to access their booking form, or on a regular cron.. every 30mins?

  • Denitsa
    • WordPress Warrior

    Hello there Adeon,

    It seems there's actually a bug in the plugin regarding this functionality and we have a hotfix available now. Our developers are working on it, so the next release should have the automated refresh between he App+ and GCal up and running. Until then, can you try replacing the /wp-content/plugins/appointments/includes/class-app-gcal.php file via FTP with the one from the .zip archive I've attached here?

    I apologise for the inconvenience and thank you for your patience!

    Cheers,
    Denitsa

  • Adeon
    • Design Lord, Child of Thor

    HI Thanks for the update..

    I have uploaded the Hot Fix.. I edited my clients GCAL and created a date blockout in their GCAL for Monday 24th April 8am-9am.. as well as Wed 26th April 8am=9am.

    I can still book these times via APP+ .. Also On Her Booking Page she has a whole bunch of BUSY times set for Saturday, and through the week. These dont match her working hours, or GCAL.. so we dont know why these times are set as busy..

    http://marilynvaccaro.com/book-a-reading/

    Also we want to have three locations for the appointments.. (Skype, Phone and a Physical location) Ive enabled the Location plugin but can not find how the client selects the location for the appointment.

    Any help would be appreciated..

    Thanks!

  • Nastia
    • Support Rock Star

    Hello Adeon , hope you're doing well!

    Also On Her Booking Page she has a whole bunch of BUSY times set for Saturday, and through the week. These don't match her working hours, or GCAL.. so we dont know why these times are set as busy..

    Would you please grant access from WPMU DEV > Support so I can have a closer look at the Appointments settings?

    Let me know when you do!

    we want to have three locations for the appointments.. (Skype, Phone and a Physical location) Ive enabled the Location plugin but can not find how the client selects the location for the appointment.

    Enable the Service Locations add-on, it will allow to bind locations to your services. Please note that only one location can be added per service by default, so the visitor should first select the location and then a service.

    This means that you will have to create multiple same services, bind each one to one location.

    Replace the [app_services] shortcode with [app_required_service_locations autorefresh="1"]. This way a visitor will fisrt select a service location and then a service. A booking page will be refreshed automatically.

    Let me know if you have any further questions!

    Kind regards,
    Nastia

  • Adeon
    • Design Lord, Child of Thor

    Hi Natsia.. I did the latest update for Appointments+ and the Synch with the Google calendar, it seems to be working, except the time is out by about an hour.. So if Gcal has an appointment at 8am - 9am.. On Gcal it comes up at 9am-10am..

    Is this a time zone issue?

    I added in the Service Locations.. and created the extra services linked to each location.

    At the moment only the location comes up, when I select location no option to choose the service comes up.. Heres the complete shortcodes im using..

    [app_required_service_locations autorefresh="1" select="Select Location:"]
    [app_monthly_schedule]
    [app_pagination month="1"]
    [app_confirmation note="Note to Reader:" phone="Phone Number:" ][app_paypal item_name="Payment for SERVICE" button_text="Please confirm PRICE CURRENCY payment for SERVICE"]

    I have given you access Via the WPMUDEV dev Dashboard.

    Thanks!

  • Denitsa
    • WordPress Warrior

    Hello Adeon,

    Awesome, it really appears it was a time zone difference issue, glad you got it fixed!

    As for the other issue, I think you're getting some kind of a conflict here with the Thrive Content Builder. When I made a new appointments page from scratch, it seems to be working as it should. You'd be able to check this out here for the frontend.

    Will you try putting the shortcodes on the Edit page screen without using Thrive and see what it does for you?

    For now you might want omit the select="Select Location:" part from the shortcode as it does not automatically change after a location is chosen. I apologise for that and I'm reporting it as a bug to our developers. I will let you know once that's fixed!

    Take care!

    Cheers,
    Denitsa

  • Adeon
    • Design Lord, Child of Thor

    Hi Denista,

    Yes theres seems to be an issue if the form is embedded in the thrive content builder. However I did find an issue with the page you created too..

    1. The user can select an appointment without choosing location or time.. It defaults to 60mins.
    2. If the user selects a location, then changes the time duration (Service) all Calendar options go RED/Busy

    Any suggestions?

  • Sajid
    • DEV MAN’s Sidekick

    Hello Adeon,
    Hope you are doing good today!

    I am really sorry for the delay on this ticket. But I still, have not heard back from the developer.

    I have pinged the developer again requesting a hotfix/patch (if possible). As soon as I will hear back from the developer. Either myself or support person will post a reply here.

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.