Author Meta Box Only Shows 1 Author

In post edit screen, this meta box only shows me, the super admin, I need to be able to change the author of posts to one of my editors. How?

Thanks.

  • coreymj78
    • Site Builder, Child of Zeus

    Ok, I got this fix from this forum (below), but now it's showing all the site users (even members and subscribers) in the author drop down. Also, when logging in as one of my Editor's, they still can't see anything in the Author drop down (not even the menu itself). How to edit this code to remedy this?

    // Filter to fix the Post Author Dropdown
    add_filter('wp_dropdown_users', 'theme_post_author_override');
    function theme_post_author_override($output) {
    global $post, $user_ID;
    
      // return if this isn't the theme author override dropdown
      if (!preg_match('/post_author_override/', $output)) return $output;
    
      // return if we've already replaced the list (end recursion)
      if (preg_match ('/post_author_override_replaced/', $output)) return $output;
    
      // replacement call to wp_dropdown_users
    	$output = wp_dropdown_users(array(
    	  'echo' => 0,
    		'name' => 'post_author_override_replaced',
    		'selected' => empty($post->ID) ? $user_ID : $post->post_author,
    		'include_selected' => true
    	));
    
    	// put the original name back
    	$output = preg_replace('/post_author_override_replaced/', 'post_author_override', $output);
    
      return $output;
    }
  • Arun Basil Lal
    • New Recruit

    I did some hunting and came across this code as well on one of the WordPress forums. Strange that many users are having the same problem over time and nothing has been done to fix it up.

    Check this one: http://wordpress.org/support/topic/post-author-problems?replies=18#post-565815

    Lets give it one more try before we go after the code? Shall we?

    Go to Users and select all the users and do a bulk "change Role to" something else. This should reset the things and make it work. You can do it in groups, like change all the editors to subscribers, and then back to editors. Then do all the Authors to subscribers and then back to Authors and so on..

    Can you give it a shot and let me know?

  • coreymj78
    • Site Builder, Child of Zeus

    Tried no luck. I don't know what the solution is, but as inconvenient as it is, i'll have to disable this feature for clients (and just use the function I posted above for my own admin use) until they come out with a fix for this. This means removing the Author drop down meta box in post / page (as well as other) editors, for non-super-admins. I just think it's strange that so many multisite admins out there are experiencing the same thing, yet as you say, nothing has even been officially done or said about it. Do you know if there has even been a bug ticket opened for it on wordpress.org?

    If clients need to change the author of a post, they will have to come to me to do so. Kind of lame, but I can't see any other way for now can you?

  • aecnu
    • WP Unicorn

    Greetings coreymj78,

    Just touching base with you to acknowledge that WordPress has designed it this way regarding user roles and profiles that only the Super Admin can change them or more accurately aspects of them but including roles as indicated in this thread:
    http://wordpress.org/support/topic/in-wp3-multisite-how-admin-can-edit-user-profiles

    It is by design and the reason given is that when a user role or profile is changed on one site it is changed for the entire network - therefore the restriction to the Super Admin.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.