Authorize AIM third party API support

I was trying to use the new support for 3 third party AIM style api gateways, when added the api url and adjusted my creds I get an error from my api that the:
x_delim_data must be set to truu
no matter what I have the delim data dropdwon set to

I cloned the authorizenet-aim.php getway plugin, went into the code and hard the x_delim_data to be "TRUE" my api transactions works after making this change.

I am thinking something must be wrong with the delim data dropdown setting. I would prefer to use the authorizenet-aim plugin so that I don't have to manage my own.

One more question will auto updating the plugin overwrite my custom gateway plugin?

Thanks