authorize.net transaction missing details

Can you help us figure out what's wrong here?

We have all of the working ID and Transaction Key info in for our Authorize.net AIM gateway.

Transactions are going through, however the orders are missing the name, email, billing info, etc. That info appears during checkout confirmation, but once the order goes through the Billing and Shipping Address show up blank with just a comma (see screenshot).

We turned on Transaction Details API at Authorize account, and made sure the delimiter is set to Yes with the default comma, and the encapsulation is left blank. This matches with the info on the plug-in side of things, too.

Can you help up get our store fully working online? thank you!

  • Milan

    Hello @lsschocolates,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    Now First of all on behalf of all WPMU DEV team I welcome you to our awesome community. :slight_smile:

    While investigating about your issue on my sandbox site I got to know about another possible bug with authorize.net in which payment was not going forward from checkout page. But as I can see its successfully going on your site can you allow me to access your site and see your configurations ? To dig deep in your issue I need access to your site so that I can confirm your configurations and try to replicate on my side. If you don't mind can you grant me temporary access to your site ? Please refer this manual to know how to do so ?

    Looking forward to hearing back from you.

    Cheers,
    Milan

  • Milan

    Hello @lsschocolates,

    I hope you are well today.

    First of all I want to inform you that the possible bug which I mentioned on my first post was actually issue of my database installation. Tried on fresh installation and everything went smooth with authorize.net payment gateway.

    I tried to replicate issue on my sandbox site by making my plugin configurations same as yours but no luck so far. So it seems to me that there could be issue on you end like plugin or theme conflict ?

    I suggest you take down plugin and theme conflict issue first by following simple procedure stated in our support manual here as flowchart. :slight_smile:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Once you conduct these two testes please share your results with us. :slight_smile:

    Cheers,
    Milan

  • Darlynne

    Ok, did you actually get it working when you tested it?

    Because we tested an order on the default Twenty Fifteen Wordpress theme, all plug-ins turned Off (other than mpmu dashboard and marketpress), ordered a test order, same issue: transaction goes through, but without the name and address info included... (see screenshot attached)

    Contacted Authorize.net and they don't see the details coming to them in the transaction.

    We have everything set up for the transaction to go through, how does this data go missing? Please help we really need to get our online store up and running asap!

    Thank you!

  • Milan

    Hello @lsschocolates,

    I hope you are well today and sorry for being late on this.

    Yes I made doubly sure that transaction details are captured on my sandbox site during performing authorize.net transaction and in this post I am attaching screenshots which will prove that. :slight_smile:

    Now if you don't mind I would like to use my sandbox credentials on your site. If its okay to you please let me know so we can move forward with some further troubleshooting.

    Cheers,
    Milan

  • Milan

    Hello @lsschocolates,

    I hope you are well today and thanks for allowing me to test with my sandbox credentials.

    Are you able to see transactions on authorize.net's merchant panel ? I just noticed that transactions are being displayed as paid on wordpress admin side but no entry being made on authorize.net's merchant panel. So what is status on your end ? Please login to your authorize.net account and navigate to Search > Unsettled Transactions and see are you able to see any entry there ? If not then please perform one more transaction and see if you get any entry there.

    Let me know what you see on authorize.net's merchant panel.

    Kind Regards,
    Milan

  • Darlynne

    Ok, logged into Authorize. Clicked "Search > Unsettled Transactions"

    I see 3 results, first one is "Captured/Pending Settlement", the other 2 say "General Error".

    After I click on the first one's Transaction ID, I see Authorization Information filled out with things such as Authorization Amount, Date/Time, Authorization Code: (blank), Ref transaction ID: Not Applcable, Transaction Type: Authrization w/ Auto Capture, Market Type: eCommerce, Product: Card Not Presnet, Address Verification Status: AVS Not Applicable (P), Card Code Status: No Match, CAVV Result Code: Not Applicable, Fraud Scroe Appliead: Not Applicable, Recurring Billing Transaction: N, ....

    , I see payment information filled out with card data things, I see Order info filled out, but again all Customer Billing and Shipping information are blank. A bunch of blank fields after Name, Company, Address, City, etc.

    So I'm going back to our Store, ordering a $5.00 gift certificate now... continuing as a guest... (logged out of Wordpress), and at the checkout screen I do see all of my info (name, email and address) under Billing and Shipping...

    Ok, entering in my payment info ... then clicking Submit Order....

    Running into this message:
    Oops! An error occurred while processing your payment.There was a problem finalizing your purchase. The merchant login ID or password is invalid or the account is inactive.

    Usually at least the transaction goes through, this error message usually comes up if the options are not correct in the Payment Settings...

    So I'm logging into Wordpress and I see Payment Settings checked to "Sandbox", so I changed that back over to Live, and then I put the comma into the delimiter field...

    trying again to purchase an item....

    looks like order goes through now, I have option to create account, I see my Order Status Screen, and it's the same, Billing Address and Shipping Address are blank except for one random comma in the blank space (see image attached).

    and over in Authorize "Search > Unsettled Transactions" I see this recent transaction. Clicking in the Transaction ID I get same details as above, all customer billing and shipping fields blank.

    What should we do? thank you for your help!

  • Adam Czajczyk

    Hello Darlynne,

    I hope you're well today!

    Reading your recent post here made me think that you could try with a bit different settings. In case it doesn't help we'll at least be able to eliminate some potential reasons for the issue.

    Please try these steps "one at a time": if one doesn't help, try next one.

    1. On you "Store Settings -> Payments" page in "Delimiter Character" option please remove the comma. Comma (",") is a default value and will be used by plugin if no other value is set here.

    2. Try setting "Encapsulation Character". In case e.g. an address may include comma character, this will help differentiate delimiter from valid part of data. I'd suggest putting the most uncommon character you could think of (in relation to the data customers may use) such as e.g. "|"

    3. Try switching "Delim Data" option to "No" instead of default "Yes"

    In case it didn't help please also test combinations of above options and let me know how it went.

    Kind regards,
    Adam

  • Darlynne

    Thanks, Adam - here's my results following your list. May be helpful?

    1. Tried that, same result... transaction goes through and comes back with all blank fields for name, billing and shipping, same old issue either way here...

    2. I tried every combo of delims I can think of already; changed them for temp testing on the authorize side, too, just to see... But sure, following your requests just to try again, and I get the same results... transaction goes through but strips away all customer data, only comes back with empty space and a comma. Something does seem strange here related to the delimiters but I am having no luck with any combinations to get the customer data after the transaction goes through, and same on the authorize side, no customer data..

    How can ship or email if that info isn't there? how does the transaction even go through without an address or email in the first place?

    What could be the cause of this error?

    3. Transaction does not go through at all after changing this setting.

    Any other suggestions/ideas? Thank you for your help, we need to get this cart online and working as soon as possible.

  • Darlynne

    Hello there!
    Can you please offer us another solution to get our payment gateway working?

    We're thinking it's time to migrate to WooCommerce or another platform, but all of the lost work we set up with our products would be such a loss of time...

    We have done extensive tests from multiple computers, contacted Authorize (they are not receiving the shipping/billing data), changed the setting several ways during testing, and have now got everything back to the Settings recommended by Marketpress, still the same error.

    We tested it after turning off all the plug-ins and using 2015 wordpress theme, and the same error occurred (see log above).

    Here's a guide that Authorize said we should look at for AIM method, updates to their System as of Dec 2015,
    http://www.authorize.net/content/dam/authorize/documents/AIM_guide.pdf

    I've goner over it several times and can't see anything else we need to do from our end, maybe Marketpress needs to be updated for it to work?

    Please assist us with any suggestions and/or solve this issue. Maybe we need to move away from Authorize.net, is that gateway having issues for other customers or ? What would you recommend?

    We're going to make a hard decision either way on March 1st, need to get the store up in time for our online sales for the upcoming Easter Holiday!!

    thank you

  • Darlynne

    Also just to confirm: We've just contacted Authorize.net again, and they are definitely not receiving any of the customer info (name, address, email) ... We used their virtual terminal and things are working internally there.

    We contacted our Host server and everything is good with the SSL.

    We tried turning off all plugins and custom themes.

    We have our Marketpress side of things all setup the way explained, and we tried several options, it's all back to the Authorize.net defaults...

    Can you please log into our site and see if you can fix or at least pinpoint this issue?

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.