Authors edit permissions conflict

Hi,

I find a strange bug in This plugin.

I activate it for managing SEO in this site but after that all the Authors of the blog cannot edit their previous posts and cannot add new.

No error, only a blank page when trying to save the edits.

  • Federico
    • Design Lord, Child of Thor

    Hi Arun,
    Sorry for delay, busy days here.

    I upgrade the plugin and reactivate it, but problem still remain. So I deactivate it again.

    I have a lot of plugins in this installations:
    Adminimize
    Antispam Bee
    AutoBlog
    BP Blog menu for Wordpress
    BP Disable Activation
    BuddyPress
    BuddyPress Automatic Friends
    BuddyPress Live Notification
    BuddyPress Template Pack
    BuddyPress Utech User Manager
    Easy CC License
    Exploit Scanner
    FancyBox for WordPress
    Floating Social
    Gravity Forms
    Gravity Forms User Registration Add-On
    Insights
    Popover plugin
    Post Voting
    Reveal IDs
    SlideDeck for WordPress - Slider Widget
    TinyMCE Advanced
    Transposh Filtro per Traduzioni
    Tweet Blender
    Twitter Tools
    Twitter Tools - Bit.ly URLs
    Twitter Tools - Exclude Category
    Twitter Tools - Google Analytics Tagger
    Twitter Tools - Hashtags
    User Role Edtor
    WordPress Amazon Associate
    WordPress Database Backup
    WP-PostViews
    WP-SpamFree
    WPMU DEV Update Notifications
    WP No Category Base
    WP Remote
    WP Super Cache

  • Arun Basil Lal
    • New Recruit

    omg! That's a ton of them. This could very easily be a plugin conflict. Can you deactivate the plugins and see if the issue still exists?

    If it goes away when you have deactivated all of them, start activating one by one, and check in between activations to find out which is the conflicting plugin.

    Let me know okay? Good luck!

  • aecnu
    • WP Unicorn

    Greetings Federico,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • Federico
    • Design Lord, Child of Thor

    Hi Joe,

    Thanks for your interest.
    No solution. I try all, but nothing to report for better understanding.

    This site is an old one upgraded and revamped with some social plugins like buddypress. All good but not with this plugin.
    Can this be related with User Role Edtor plugin? I really don't know.
    Deactivating it is not the solution, so I deactivate the SEO plugin.

    Thank you.
    Kindly regards,
    Federico

  • aecnu
    • WP Unicorn

    Greetings Federico,

    In review of the many plugins on this site I do not even know where to start to look for which plugin is causing this anomaly/conflict with Infinite SEO, the possibilities are many.

    The only way to truly get to the bottom of this is to follow standard trouble shooting protocol and deactivate all plugins (except Buddy Press) to see if this cures the anomaly and if it does, activate them one at a time testing in between until we hit the conflict.

    Then we have something to present to the developer and have them look over the code to find the conflict.

    If in fact it turned out to be User Role Editor plugin I would then recommend Advanced Access Manager plugin as a possible replacement.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Federico,

    As i reviewed this entire ticket it suddenly came to mind that the blank page symptom may be a php memory problem meaning not enough php memory allocated to be able to run both the Infinite SEO plugin and your WordPress installation.

    So lets see what we can dig up.

    Below is a zipped phpinfo.php file that you could download, unzip, and then upload to the root of your domain.

    Call it up in your browser like http://yourdomain.com/phpinfo.php and check the following items:

    memory_limit

    max_execution_time

    Please let me know what they currently are so I may possibly offer a recommendation that may just clear these symptoms right up.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Federico,

    Personally I do not pay attention to nor worry about the define('WP_MEMORY_LIMIT', '64M'); in the WordPress configuration file due to as you can see it has no effect on the actual memory_limit, and this statement define('WP_MEMORY_LIMIT', '64M'); does not appear at all in my WordPress MultiSite install.

    The memory_limit is defined in your php.ini file of your hosting account.

    Your max_execution_time setting is way up there and is certainly not an issue.

    See if you can set the memory_limit to at least 64 MB but preferably 128 MB if possible.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Federico,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.