Auto-blog duplicate posts since last week, it was working fine over the months

It happened since last week, it duplicates posts and put it under default category. Our feeds are normally have their own categories.

It caused a lot of trouble now. Unsure it was the reason of updated to the new wordpress 4.1.5.

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I hope you are well today and many thanks for your information.

    I've checked your feed & posts data, everything seem fine. Can you please let me know which post getting duplicate? If you can send me some links, that will be great.

    Thanks!!!

    Best regards,
    Hoang

  • tigernsw
    • Design Lord, Child of Thor

    Please see attached.

    Category "Promotion" is the default category, such as "uncategorised" when you setup a new Wordpress site. It seems to me all the duplicate posts are using this category. Which the correct imports are setting to be imported into different categories.

  • Ash
    • WordPress Hacker

    Hello @tigernsw

    I have just tested with your feed in my test site and it worked perfectly fine.

    I tried to login at your site and got an access token error. Would you please enable support access again?

    And before that, would you please run a plugin conflict test? Please deactivate all plugins except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    You can create a test site and use a fresh autoblog install in there to test if you don't wan't to test in live site.

    Please let me know what you get.

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hello @tigernsw

    I just tested in another site and could not replicate the issue. But I can see you have some same posts in trash.

    So, a test site would be great. In that test site, add no other plugins but Autoblog only and activate default theme, then run the feed and let me know.

    Also enable support access of that test site too.

    Cheers
    Ash

  • tigernsw
    • Design Lord, Child of Thor

    Here are the comments from the system engineer:
    The size issue isn't actually with the database, but with the cache directory located at /home/forextel/public_html/wp-content/cache, which is just about a gig. The autoblog plugin appears to be flushing the cache, so it is checking each and every file in there which takes a substantial amount of time.

    The memory limit was a separate issue which was throwing a different error, once that was resolved we came across the timeout issue, so it would not be beneficial to revert the mem_limit changes.

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I hope you are well today.

    Can you please provide me more info on the size issue. Look like it is w3t cache issue, not AutoBlog. If you using file cache, w3t will store the page as static file, and when user request that page, w3t will load & display the static page instead of letting WordPress querying the data from Database.

    Please advise,
    Thanks!

    Best regards,
    Hoang

  • tigernsw
    • Design Lord, Child of Thor

    I've setup to VPC without setting as DISK in w3t. But the issue is the same.

    About the "size issue" in ur last reply. We tried to increase to 2G memory to wordpress and php but it still failed. Please let me know if it's not the information you need or you need some more information.

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I hope you are well today.

    About the "size issue" in ur last reply. We tried to increase to 2G memory to wordpress and php but it still failed. Please let me know if it's not the information you need or you need some more information.

    Do you receive any errors? Can you please post a screenshot where it fail, that will help me :slight_smile:

    Thanks!,

    Best regards,
    Hoang

  • Hoang Ngo
    • Code Slayer

    @tigernsw,

    When you get blank page or 503 error, that's mean your server has setup for preventing error output, but it should log the errors.

    I saw you are using cPanel, so can you please send me the login info, I can check the error log there. Also, I've sent you an email for cPanel info, you can reply the email with the access info :slight_smile:

    Thanks!

    Best regards,
    Hoang

  • tigernsw
    • Design Lord, Child of Thor

    I've replied ur email.

    I have also tested on staging.forextell.com but it's very different, which auto-blog simply stopped working at all.

    =============================================
    Hi Tiger,

    I installed a cron-viewer plugin on staging.forextell.com and from that I am able to verify that the cron is running. Here are some relevant entries below.

    May 13, 2015 @ 3:13 (1431486830) autoblog_process_feeds
    May 13, 2015 @ 6:27 (1431498474) autoblog_process_feeds
    May 14, 2015 @ 4:36 (1431578193) autoblog_process_feeds
    May 14, 2015 @ 4:43 (1431578580) autoblog_process_feeds
    May 14, 2015 @ 5:07 (1431580024) autoblog_process_feeds
    May 14, 2015 @ 5:09 (1431580172) autoblog_process_feeds
    May 14, 2015 @ 5:11 (1431580309) autoblog_process_feeds
    May 14, 2015 @ 14:11 (1431612692) autoblog_process_feeds
    This demonstrates that wp-cron is working as it should, but that there is a problem with the plugin itself. I see that the autoblog plugin is a paid plugin that comes with support, so I would recommend contacting WPMU DEV (that makes of the plugin) to troubleshoot this issue further.

    If you have any other questions please let me know.

    Thanks,

    Linux Enterprise Support

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I found in your wp-config.php this line

    /** disable wp crons - jburke */
    define('DISABLE_WP_CRON', true);

    This mean you disabled the WP Cronjob, do you setup any System Cronjob as a replacement? If not, that's mean all the WP cron tasks on your site stopped too.

    Cron Viewer only query the scheduled tasks in database and display them, the only thing it can say is your tasks have in queued, but for processing theme, the plugin won't give us any information.

    For the blank page issue, I found some errors like this
    Maximum execution time of 30 seconds exceeded in /home/forextel/public_html/wp-includes/cron.php on line 0
    This mean when processing cron tasks, it's take longer than 30 seconds, and then PHP will trigger a fatal error. Please add this code to your wp-config.php
    set_time_limit(60)
    This will increase the limit time to 60, hope it will help :slight_smile:

    Best regards,
    Hoang

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I increased your MEMORY_LIMIT to 512M, the feed process action should works fine now.
    I've extended the AutoBlog logs to 2 weeks, so we can trace the duplicate bugs.

    I'm sorry for this inconvenience and many thanks for your patience.

    Best regards,
    Hoang

  • tigernsw
    • Design Lord, Child of Thor

    Hi Hoang,

    Thx for ur help.

    Can u please let me know where you setup MEMORY_LIMIT to 512M? I remember we have tried to setup the memory to 1G on production site, but the issue is still there, I'll double check.

    Regards
    Tiger

  • Hoang Ngo
    • Code Slayer

    Hi @tigernsw,

    I hope you are well today.

    I has placed that code inside the file wp-config.php. I saw you using the constant WP_MAX_MEMORY_LIMIT for define the memory limit, but this is only affects in the administration area, on frontend, if I remember right, the the memory limit is set around 96M.

    Best regards,
    Hoang

  • Vinod Dalvi
    • WP Unicorn

    Hi @tigernsw,

    Would you mind if I logged in to your site staging.forextell.com and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi @tigernsw,

    Thank you for granting the support staff access.

    I could confirm the feed is not importing on your staging site. I have also tested it on your site using another test feed but it also didn't work.

    I tried to test it by temporary disabling all other plugins but when i tried to disable them, i get the following error message.

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/forextel/public_html/wp-includes/wp-db.php on line 2482

    It seems this maximum execution time error is also causing the issue with importing feed so could you please try increasing it as described on the following pages and also as described on this thread previously.

    http://www.wpbeginner.com/wp-tutorials/how-to-fix-fatal-error-maximum-execution-time-exceeded-in-wordpress/
    http://w3guy.com/maximum-execution-time-exceeded/
    http://stackoverflow.com/a/5164954/1287548

    If it doesn't help you then would you mind if I access your site using FTP and did some testing? This might help get to the bottom of this faster. If this is ok, just send log in info through our secured contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Vinod Dalvi"
    - Include the URL of this post in your message so that I may track this issue better
    - Include login information (Wordpress admin info username + password )
    - Include FTP Details

    Regards,
    Vinod Dalvi

  • tigernsw
    • Design Lord, Child of Thor

    Hi Vinod,

    I have setup the maximum time to 120 seconds. I have sent Hoang the FTP info via the contact us form before, I can resend if u can't find it. But it'll be next day as I'm not with my PC at the moment.

    Regards
    Tiger

  • Ash
    • WordPress Hacker

    Hello @tigernsw

    Please send the information that Vinod asked when you get some time. But before that, would you please try the solution that Hoang did for your other site? Adding the following in wp-config.php:

    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Also, are both sites in same server?

    And when you increased max execution time, did you restart your server? What happens if you disable all other plugins? And make sure you dont have wp cron job disabled.

    Cheers
    Ash

  • tigernsw
    • Design Lord, Child of Thor

    >>>Please send the information that Vinod asked when you get some time.
    Done.

    >>>>But before that, would you please try the solution that Hoang did for your other site? Adding the following in wp-config.php:
    define( 'WP_MEMORY_LIMIT', '512M' );
    define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Done.

    >>>>>Also, are both sites in same server?
    No, they are on different servers.

    >>>>And when you increased max execution time, did you restart your server?
    Yes.

    >>>>What happens if you disable all other plugins?
    You can have a try.

    >>>>And make sure you dont have wp cron job disabled.
    It has been adjusted by jburke from ur team, it's enabled.
    But when we implement on production site, we'll have to disable it as we need w3t which may cause wp_cron issues.

  • Vinod Dalvi
    • WP Unicorn

    Hi @tigernsw ,

    Thank you for sending the site details.

    The auto-blog doesn't work at all on staging.forextell.com now. There is no feeds imported. Please see attached.

    It seems it's working fine on your staging site now staging.forextell.com as shown in the attached screenshot.

    Please advise.

    Regards,
    Vinod Dalvi

  • Patrick
    • Support Monkey

    Hi there @tigernsw

    I hope you had a great weekend!

    From what I can tell by @Vinod Dalvi's reply, he didn't do anything but check your site. It is quite likely that the changes that previously recommended, and which you implemented, have done the trick. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.