Auto-created Google Map, Hide the Marker

I am using the option to pull the lat/long from custom fields, which works great. I appreciate having the map centered, but don't need a marker, since the point is meaningless, as my focus is on counties.

How can I suppress the blue marker, or maybe make it a 1x1 clearpixel.gif or other workaround?

Thanks.

  • kenlyle
    • Site Builder, Child of Zeus

    Thanks. That seems like a long way to go for what could be a checkbox in the Admin.

    I have to init the Marker Manager before the hide will work, but if the user scales the map, the marker will show again, unless I move it outside the map, but if I want to show it again I have to rewrite or override the show function....sure, of course.

    Can you maybe just point me to the plugin code where it decides to show the marker for the location of the custom fields? I really only intend to use those for centering, they are not the location of anything, really, not even the centroids of the counties, it turns out...

    Thanks!

  • aecnu
    • WP Unicorn

    Greetings kenlyle,

    Thank you for letting me know your thoughts on this though not being a coder I do not know what/where to advise you to adjust.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings kenlyle,

    Thank you for your input and indeed sometimes he could indeed appear to be a mythical creature ... lmao ... but he is real I can assure you talent of this degree is always working on something :slight_smile:

    Looking forward to his input as well.

    Cheers, Joe

  • Vladislav
    • Dead Eye Dev

    Hi,

    The latest plugin release (v2.6, just released) comes with a couple of new add-ons. One of them is geared specifically for this situation - activating the add-on titled "Hide auto-created Markers" will automatically suppress the markers on the auto-generated (auto-inserted) map. You can also add this functionality to your other maps you insert via shortcode, by using the "hide_map_markers" shortcode attribute and setting it to "true".

  • kenlyle
    • Site Builder, Child of Zeus

    Thanks!

    Can we get these notices fixed?

    Notice: Undefined offset: 0 in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 583

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 586

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 590

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 590

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 590

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 591

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 591

    Notice: Trying to get property of non-object in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 591

    Notice: Undefined index: id in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 323

    Notice: Undefined index: show_posts in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 456

    Notice: Undefined index: show_images in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 458

    Notice: Undefined index: image_limit in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 460

    Notice: Undefined index: show_panoramio_overlay in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 461

    Notice: Undefined index: panoramio_overlay_tag in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 462

    Notice: Undefined index: street_view in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 463

    Notice: Undefined index: street_view_pos in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 464

    Notice: Undefined index: street_view_pov in plugins/wpmu_dev_maps_plugin/lib/class_agm_map_model.php on line 465

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.