Auto Posting

I get a 200 error code when trying to auto post. This is the message from the company that does the autopost:
IMPORTANT!!! So we can post successfully to your blog, your hosting has to accept something called XML-RPC connections. It may also need to have our IP 107.173.57.119 'whitelisted'. Our system uses XML-RPC connections to your blog in order to be able to post articles and images for you.

If you're not sure about your hosting setup, please give this entire message to your hosting support and ask them to ensure that your site settings are correct for this. It's best to do that before you add a blog here.

  • Adam Czajczyk

    Hello David

    I hope you're well today and thank you for your question!

    The XML-RPC is a special "interface" that allows remote posting. This is enabled by default in WordPress so unless you're using some security plugins that might be disabling it, it should already be on.

    That being said, I noticed that you're using CloudFlare CDN for your site. According to their docs, xmlrpc.php file (which is responsible for XML-RPC intefrace) is protected and only allowed for JetPack plugin. That means that any XML-RPC based service that connects to your site will not work.

    Additionally, there might be some lock on this put by your host but as long as the CloudFlare is on, you won't know that. Therefore, to check this, go to your CloudFlare setttings and temporarily put it in "dev mode" or disable entirely.

    If that auto-posting works then, you'll know that it's only a matter of CloudFlare. If not, you will need to get in touch with your host and forward that message that you posted here to them, asking them to check if they could white-list the IP mentioned there and if they do have any additional limits on XML-RPC.

    If it turns out that switching off CloudFlare only solves that, I'm afraid you might need to get in touch with CloudFlare support asking them if it's possible to overcome. I'm not that familiar with their options and it might require changing some configuration options at CloudFlare settings so they should able to help - if that's possible to "open" that access on their end at all.

    Kind regards,
    Adam

  • Predrag Dubajic

    Hi David,

    So you're still using Cloudflare is that correct?
    This error you are having is related to Cloudflare and it shows that something is timing out, it's strange that they couldn't give you any further info as the 524 is Cloudflare specific error.

    Can you check if you have "Blocks amplified brute force attempts to xmlrpc.php" and "WordPress Pingback Blocker" options enabled in Cloudflare settings and try disabling them to see if those could be causing this issue for you?

    Best regards,
    Predrag