Auto Sync keeps failing

I am trying to add sites to my hub using auto sync and it keeps failing. Chat support gave me ip addresses to have my host add to firewall, but it's still not working. My server support said they didn't see any blocked attempts of those IP addresses and asked what ports the process uses so he could check that. Any ideas? I got disconnected with Chat support so someone (I think Violeta?) is already looking into the issue. Thanks

  • edelta
    • WPMU DEV Initiate

    Yes, if I install the dashboard plugin manually, and enter my wpmudev account and password, it connects. All the domains in the hub work once manually installed..updates, installation of other plugins etc.

    I just tried another and it worked for the first time. Will update if I get the error again.

    thanks

  • edelta
    • WPMU DEV Initiate

    Well, the next one failed like the others. This is the error message I got and received for all the others but one.

    We hit a snag while auto-installing the WPMU DEV Dashboard plugin on *******.com. So let's install it directly or try again

  • edelta
    • WPMU DEV Initiate

    Another one failed, and it's updated with latest wordpress and everything is updated so that apparently is not a factor. I tried it twice and both times it failed. The domain is mcgeheechamber.com Can't think of anything different about it and the last two that worked. Very weird.

  • edelta
    • WPMU DEV Initiate

    Regarding the ports, this is the reply from my server support:

    "There should not be any issues using those ports as they are open in the both incoming and outgoing direction. Since I was not able to find any errors, I would expect some conflicts between plugins in wordpress itself. Which those errors may or may not show up in any logs."

    Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello @edelta!

    The "mcgeheechamber.com" is on of those domains where the automatic install failed but then it worked when you manually installed WPMU DEV Dashboard (and now all the installs/updates are working there too), correct?

    Would you mind enabling support access to this site so I could take a closer look at its configuration and basic server configuration/parameters? You can do it on "WPMU DEV -> Support" page in your site's back-end by clicking on "Grant support access" button.

    Let me know here, when it's enabled please.

    Kind regards,
    Adam

  • edelta
    • WPMU DEV Initiate

    Disregard my last post. I thought you meant on the WPMUDEV website. I found it in my wp-admin under WPMUDEV. That's a very neat feature that I didn't know about.

    edit: I just saw your screenshot. :slight_smile:

    thanks
    Kurt

  • Predrag Dubajic
    • Support

    Hi edelta,

    Thanks for granting access, and adding cPanel login details in there.

    I had a look at your logs and based on those the connection to your site was successful but something locally declined the plugin installation.
    This is what I'm referring to in the log:
    66.135.60.59 - - [12/Dec/2017:13:40:56 -0500] "POST /wp-load.php?wpmudev-hub=5a3022bXXXXX-1513XXXX056.4925 HTTP/1.1" 200 370 "http://mcgeheechamber.com/wp-load.php?wpmudev-hub=5a3022bXXXXX-1513XXXX056.4925" "Mozilla/5.0 (compatible; WPMU DEV Hub/2.0; +https://premium.wpmudev.org)"
    200 response from that suggests that the connection was successful so it's something after that preventing the installation.

    Can you provide this information to your host so they can double check the permissions and see if there's anything on their server blocking the plugin installation this way?

    P.S. While I was checking your installation I noticed in wp-config.php your DISABLE_WP_CRON was defined at the end of the file so I moved it above /* That's all, stop editing! Happy blogging. */, because there shouldn't be any custom code added below that line.
    It's probably not what caused the issue but it's better to keep things in correct place as it can cause other issues if misplaced.

    Best regards,
    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hi edelta,

    Yeah, that's what my server support just told me. I don't know why or when they made that change. They are going to add WPMUDev's ips. thanks

    Keep us updated on the issue, please, so we could keep track of what's happening and follow up until this is solved :slight_smile: Thanks!

    Best regards,
    Adam

  • edelta
    • WPMU DEV Initiate

    It appears the deny/allow code that was added to the htaccess file of some of my websites was the problem. I have now successfully installed two sites that didn't have that code added. Apparently, it blocks the installation of the WPMUdev dashboard, but once the dashboard is installed, it's able to connect. I assume adding the dashboard requires access to the wp-login, but once it's installed, it connects through the dashboard plugin?

    Thanks

  • edelta
    • WPMU DEV Initiate

    Also, the auto sync feature will not install the dashboard if you have renamed our wp-admin file. I had used a rename login wp plugin which is no longer updated, and I had to deactivate it for autosync to work.
    Thanks for your help.

  • Predrag Dubajic
    • Support

    Hi edelta,

    Thanks for all of the additional info, Auto Sync does indeed need access to login page in order to install the Dashboard plugin for the first time, after that the process is done via the API from Dashboard and that's why you didn't had any issues after manual installation.

    Same thing is with renaming wp-admin, so in these cases you should either disable the protections before using Auto Sync or install the WPMU DEV Dashboard manually.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.