AutoBlog Add-On (Replace Author Information) WP_Widget error

When activating the AutoBlog Add-On (Replace Author Information) I get a white screen and the debug issues the WP_Widget deprecated error. FYI

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
__construct()
instead. in /home/commit89/public_html/wp-includes/functions.php on line 3624

Please update add-on
Thanks!

  • Vaughan

    Hi Josh,

    Hope you're well?

    This is just a notice and as such shouldn't break anything, whatis causing the whitepage is WP_DEBUG itself as the debugger can conflict with Javascript & so on.

    Can you try the following,whichshould hide the debug noticeand instead write the debug errors to a file instead of the screen.

    find WP_DEBUG in your wp-config.php

    Now set it to false. If it's already set to false, that's fine. but add the following lines below the debug line soit looks like below.

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Now the debug notices shouldn't be displayed ons creen, instead they will be written to a file called debug.log in your /wp-content folder.

    Either way though, I have reported this as a bug as notices are still annoying and should be fixed.

    The issue isn't with the author add-on though, it's in the twitter add-on.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.