Autoblog does not process feeds - cron / cdn / cache problem?

Autoblog does not get executed on schedule, in several blog / feed combinations. The feeds are valid, they do get processed when I manually click "Process".
Both blogs get thousands of pageviews daily, so lack of activity could not be the problem.
However, I am using Incapsula CDN (similar to CloudFlare) and Google Page Speed Service - could these be the problem, i.e. viewers not hitting WP but the cached version? In that case can I use an external cron job? ( I am outside my comfort zone with this, would need actual syntax to set up).
Thanks a lot!

  • Timothy Bowers

    Hey zerdos

    I suppose it could well be cache, not sure of your set up as I don't use those methods.

    What happens when you turn all those caching options off, and deactivate all other plugins. Does it work then?

    For running a manual cron I think first you would disable the normal cron in wp-config.php

    define('DISABLE_WP_CRON', true);

    Do you use cPanel?

    You can create crons in cPanel really easily.

    If not and you are not sure then you could get your host to help you here, but something like this should work:

    */30 * * * wget -q -O - >/dev/null 2>&1

    The "*/30 * * *" sends the cron every 30 minutes.

    The "> /dev/null 2>&1" ensures no emails are sent out.

    Hope this helps :slight_smile:

  • Timothy Bowers

    Hey there! :slight_smile:

    Just checking in to see how things are going with this one and if you need any further help. :slight_smile:

    We haven't heard from you on this thread for a while. So I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.