Autoblog - Error Message after latest update

After updating to the latest autoblog today, I've this error message under Autoblog's All Feeds tab. It wasn't there before this version. I believe the programmer has updated this version thinking everyone who uses SSL would buy a SSL cert. In my case for this website, I am using a self-signed cert. Tested this on another website with a purchased CA cert does not produced this error. My 3rd site that does not use any SSL also has no such error message. Think you need to code it to accept self-signed cert.

"Problem communicating with WP_CRON: Peer certificate cannot be authenticated with known CA certificates"

Anyone know?

  • aristath
    • Recruit

    Hello there @Alvin, I hope you're well today!

    I'm afraid I've never seen this error before... I have notified the plugin developer about this issue, hopefully his insights will help us figure this one out.

    Please keep in mind though that plugin developers have a lot of responsibilities so this might take a bit longer than a normal ticket.

    Cheers,
    Ari.

  • Hoang Ngo
    • Code Slayer

    Hi @Alvin,

    I hope you are well today and i'm very sorry about your issue.

    In the feed setting, can you please turn the "Force SSL verification" to "No" and please try again if that help.

    I think the reason is not in your site ssl, it's in your feed ssl certification. When the "Force SSL verification" turn to yes, it will validate the feed ssl cert and if the feed are self-signed cert, it will cause the error.

    If you have any issues please don't hesitate to let us know so we can assist

    Best Regards
    Hoang

  • Alvin
    • Design Lord, Child of Thor

    Force SSL verification has been turned OFF for all my feeds but the error message persist.

    If you look at the error message carefully, it mentions it has something to do with WP-CRON...wordpress scheduler? That's pretty internal isn't it?

    Thanks.

  • Hoang Ngo
    • Code Slayer

    Hi @Alvin,

    Can you please send me your feeds' url ?.

    If you can not send it public, so please send in

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - Include your feeds' url

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Best Regards
    Hoang

  • Alvin
    • Design Lord, Child of Thor

    Hi HN,

    I've validated all the links. They are generally just wordpress feeds. They are validated. In fact, the same feed when used on a site with public cert ssl is ok. But the message "Problem communicating with WP_CRON: Peer certificate cannot be authenticated with known CA certificates" appears at the top of ALL Feeds when used on a site with self-signed cert. It is importing the feed though. Perhaps this is a warning message instead of error message? This could be misleading.... :slight_smile:

    For your troubleshooting please.

    Regards,
    Alvin

  • Hoang Ngo
    • Code Slayer

    Hi there @Alvin,

    I hope you are well today.

    Many reasons can cause this issue, like the feed's site, server environment, etc, so I will need more information to have a closer look :slight_smile:

    Could you enable support staff login in WPMU DEV dashboard > support > support access > grant access, please :slight_smile:

    Best Regards,
    Hoang

  • Hoang Ngo
    • Code Slayer

    Hi,

    I hope you are well today.

    This issue cause when CURL trying to verify the the SSL certificate with an accepted CA in a bundled set of CA certificates. But for some reasons, your SSL certificate can not verify, you can see the acceptable CA in the /wp-includes/certificates/ca-bundle.crt

    So we will have 2 way to fix it.
    1. Update the certification path to to your new CA file, which include your SSL certificate. You can do it by
    Please add this code to your theme functions.php or use mu-plugins

    add_filter('http_request_args', 'ssl_verify_off_wp_remote');
    function ssl_verify_off_wp_remote($args)
    {
        $args['sslcertificates'] = 'YOUR NEW PATH TO CE FILE';
        return $args;
    }

    2. Remove the ssl verification, for doing this, please add this code to your theme functions.php or use mu-plugins

    add_filter('http_request_args', 'ssl_verify_off_wp_remote');
    function ssl_verify_off_wp_remote($args)
    {
        $args['sslverify'] = false;
        return $args;
    }

    Best regards,
    Hoang Ngo

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.