Autoblog. Feed is not valid

I use autoblog to import my feed ,but when I try to import I get this:
Feed URL is invalid and cannot be processed.

Also this feed is not valid: https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fblog.sillybillystoyshop.com%2Ffeed%2F+
('The read operation timed out',) (SSLError; misconfigured server?) [help]
How can I fix this? I'm the owner of this feed.

  • Huberson
    • Recruit

    Hello Robert
    The feed appears to be working fine. But there's a delay when pulling the feed data that causes it to timeout, and fail validation.

    Try increase WordPress memory on the site by adding this to 'wp-config.php' file:
    define('WP_MEMORY_LIMIT', '512M');
    Must be added before the following comment line: '/* That's all, stop editing! Happy blogging. */'.

    This timeout issue is sometimes related to a plugin using up resources, if the above doesn't resolve it you might try a conflict test by deactivating all the plugins and check the feed again.

    Hope that takes care of the issue.

    Regards,
    Huberson

  • Robert
    • WPMU DEV Initiate

    Hiya this is wp-config.php file

    <?php

    [removerd]

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    /** Up Memory
    define('WP_MEMORY_LIMIT', '512M');

    -------------
    I have put the code at the bottom is that OK ??
    Cheers

  • Robert
    • WPMU DEV Initiate

    I have been advised of the following by the support team for the server and hosting platform

    Our platform team have taken a look here and have advised that this issue does look to be related to cURL timing out here.

    This would need to be set as part of the cURL command, rather than as a platform limit on our side, so I believe you will need to contact the plugin author regarding this.

    The timeout limit can usually be set with CURLOPT_TIMEOUT.

    PLEASE HELP

  • Huberson
    • Recruit

    Hello Robert
    Sorry for the delay, I see Katya already removed the config info . Should be OK but let us know if you want to make the thread private.

    I don't think the timeout is something specific to the plugin. As you can see from W3C feed validator, the validation failed with the same timeout and SSL error.

    Did some test and the feed on the main site validated with no issue. If you have already increased the memory limit, make sure you perform a conflict test by deactivating the other plugins on the sub-site and test with W3C vaidator again.

    Do let us know if still not resolved after performing the above.

    Regards,
    Huberson

  • Robert
    • WPMU DEV Initiate

    Further to This I have now tried a Category feed and I get this
    https://blog.sillybillystoyshop.com/toys/playmobil/feed/

    RESULT
    WP HTTP Error: cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    So server support have closed the ticket their side because they say WPMUDEV cannot resolve this CURL timeout due to this thread

    Server support my side said:
    It appears that others have had this problem with autoblog and they did not find a solution with the developer.

    https://premium.wpmudev.org/forums/topic/auto-blog-errors-wp-http-error-curl-error-28

    The potential is that the feed has become too large and times out. As shown from my command line test earlier, and by actually visiting the page itself the feed is up and working correctly

    $ time curl https://blog.sillybillystoyshop.com/feed/ | xmllint --format - | head
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 982k 0 982k 0 0 98k 0 --:--:-- 0:00:10 --:--:-- 111k
    https://blog.sillybillystoyshop.com
    Toy Shop Updates in Hebden Bridge
    Sun, 11 Mar 2018 13:34:22 -0400
    en-GB
    hourly

    real 0m10.537s
    user 0m0.026s
    sys 0m0.018s

    IS THERE ANYTHING YOU CAN DO ??

    XX

  • Kasia Swiderska
    • Support nomad

    Hello Robert,

    Further to This I have now tried a Category feed and I get this
    https://blog.sillybillystoyshop.com/toys/playmobil/feed/

    I have tested this feed on my site and I could not observer any issues with it. It imported all the items from the feed.
    But that feed also shows in validator it is correct https://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fblog.sillybillystoyshop.com%2Ftoys%2Fplaymobil%2Ffeed%2F

    On the other hand, this feed https://blog.sillybillystoyshop.com/feed/ is not valid in validator.
    Let's for moment remove Autoblog from this equation (I deactiavte Autoblog) and use build-in WordPress RSS feed widget (you will find it in Appearance -> Widgets - it is part of WordPress).
    If you put this feed into this widget to pull 10 items from it you will receive the same error

    it clearly shows that problem is with feed and not Autoblog itself (I also tested another plugin that pulls items from feed and it also failed on that feed).

    So there are two issues - one is unrelated to Autoblog because feed is not valid and second that you see with https://blog.sillybillystoyshop.com/toys/playmobil/feed/ and that is valid and works on other site, but not yours.

    If your server provider was focusing on Autoblog regarding this feed https://blog.sillybillystoyshop.com/feed/ they were incorrect because it is not working even with standard WordPress widget.

    As for the second feed, can you open support access to your site so I can check this?
    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Robert,

    I checked your site and in the server configuration there was nothing that would say why this subsite feed is failing. Memory limits are looking good so we have to exclude the obvious reason that its the limit issue.
    I would like to debug this further. Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/#i-have-a-different-question :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send those credentials

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.