Autoblog is causing an issue with cached posts -- after

Autoblog is causing an issue with cached posts -- after editing a post it keeps serving an old version. Hours and hours and hours spent trying to figure out how to clear cache...deleting and reinstalling various plugins checking over and over again... thinking they were the problem, but hassle is absolutely associated with Autoblog cache. disable autoblog, correct post is served, re-activate autoblog, incorrect version is served.

no mention of 'cache' in instructions, but there are a couple of cache php files,

how do I Kill the Autoblog cache...? can happily go into mysql and delete if know what to look for

  • Adam Czajczyk

    Hey @tripvendor,

    I hope you're well today and thank you for your question!

    I'm not sure if I'm getting this correctly, so could you please explain what do you mean by "Autoblog serving posts"? The Autoblog plugin should fetch posts and put them into your WordPress database rather than server, so I suppose I'm missing something here. Please advise!

    As for cache. Autoblog itself is using WordPress built-in SimplePie implementations so in order to disable any related caching engine, we'd need to work with SimplePie config which isn't available in WordPress "out of the box".

    add_filter( 'wp_feed_cache_transient_lifetime', create_function( '$a', 'return 0;' ));

    This line should refresh SimplePie cache. Would you please add it to your theme's functions.php file and let me know if it helped?

    Cheers,
    Adam

  • Adam Czajczyk

    Hey @tripvendor,

    Thank you for this explanation, I'm not confused any more :slight_smile:

    This shouldn't be happening as once the post is created by Autoblog, it becomes just a standard WP post and Autoblog shoudn't affect it anymore.

    However, there's one more thing worth checking. For each feed added to Autoblog there's an option to overwrite duplicates. I think this is quite likely a reason. Could you please check your feeds and see if the "Override duplicates" option is set to "No" (see screenshot)?

    If it was set to "Yes" then even after you edit the post it could get overwritten with its original version on next "autoblog run".

    Let me know please if it helped!

    Cheers,
    Adam

  • tripvendor

    What it 'shouldn't be happening' and what it actually does are two different things.

    this is not related to the duplicates settings.

    I looked at another completely different site and posts are not updating there either (different browsers, cleared cache on browser and on site etc.)

    deactivate Autoblog and the edited updated post appears, activate Autoblog and it reverts to original post.

    there are two 'cache'.php files in Autoblog plugin and not sure what it might be calling from Simple Pie or whatever.

    please take a look on your test sites... post generated by Autoblog. edit it. see if updates on live. if not, deactivate Autoblog and see updated version.

    in theory this could be an issue with another plugin, or it is an inherent problem in Autoblog

    on one site I have All other plugins disabled, and it is still an issue with displaying old version

  • Adam Czajczyk

    Hey tripvendor,

    Thank you for this information!

    These "cache" files are related to images so shouldn't affect text content. I've tried to replicate the issue on my end following your instruction but cannot achieve the same effect. Once I edit the post it stays that on my test site, regardless whether the Autoblog plugin is enabled or not and if the feed is processed again (or not) automatically or manually.

    That being said, I suppose I'm missing something here. Would it be possible that I took a closer look at your site's setup? To do this I'd need to access your dashboard/network-admin via our "WPMU DEV Dashboard" plugin. If this is acceptable, please grant me a support access by following this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Thanks,
    Adam

  • tripvendor

    I am experiencing this problem on all my sites.

    So if autoblog generated posts can be edited on your network then it is a plugin conflict. all sites use genesis framework, but I would be surprised if that is the problem.

    disabling other plugins doesn't fix this, I've completely deleted other plugins that do caching too

    so it appears to be something that happens upon post creation or... ?? but where the cached posts are coming from is a complete mystery - it is absolutely connected to enabling/disabling Autoblog.

    https://plumberpress.com/wp-admin/network/ plugins on this site are representative, support access has been enabled.

    thanks

  • Adam Czajczyk

    Hey tripvendor,

    Thanks for granting an access and letting me take a look.

    On your site I have edited the "Royal Plumbing receives..." post, adding some "TEST" strings to the content. I can confirm that I can't see this on front-end view. I've checked AutoBlog settings, manually processed the feed again (posts didn't get overwritten, that's good), checked WordFence settings and took a look at some other configuration issues. This didn't help.

    However, the changes I made are still there and you should be able to see them by opening this post for editing. This leads me to a point that there's some kind of cache existing (as you already suggested) but I wouldn't bet on Autoblog itself because:

    - after Autoblog creates a post it has nothing to do with it; the post should be served as a normal WP post
    - changes are kept and visible in back-end;

    That being said, is there any chance that there's some kind of caching solution on your server's side? Are you using CDN to speed-up your site?

    Please advise!

    I'm also calling our 2nd-line support guys for help here, so hopefully they will have better ideas than me and lend us a helping hand here!

    Cheers,
    Adam

  • tripvendor

    thanks for looking into this -

    you're right first place to look on something like this would be the caching plugins/ CDN/Server cache - this is occurring on different servers, and on sites that are not using CDN. I verified with the first host (where I discovered the issue) and they state they do not have server caching.

    I created a brand new cpanel account and a new wordpress site on my VPS, installed Autoblog on a completely generic brand new untouched (permalinks changed) site, created some autoblog-posts... they won't update with Autoblog enabled. Disable Autoblog and they update.

    Regular posts update without issue.

  • Hoang Ngo

    Hi @tripvendor,

    I hope you are well today.

    I've take a look at your site, the reason is the AutoBlog add-on Open links in popup enabled. This add-on has a built-in cache for speed up the performance. For avoiding that, you can click on the option Always refresh content, which will fix this issue.

    Please check my screenshot for more information :slight_smile:

    If you have any additional issues, please let us know and we'll be happy to help..

    Best regards,
    Hoang

  • MELONPUP

    Hi,

    I know this post is old, but I've also been experiencing exactly the same issue.
    I also believed it was a caching issue, except for the fact that changes to Pages, other Posts (non-AutoBlog) and to the Theme, all updated instantly.

    Going through the wordpress database, I found the "meta_key" entry of "autoblog_open_source_popup" within the "postmeta" table.

    When I deleted the contents of the "meta_value", the Live Published Post refreshed correctly.

    However, I then made another change to the post, but this did not appear.

    Searching these forums for "autoblog_open_source_popup", I found this article.

    Fortunately, the comments by "Hoang" saved the day. But I had to make the change to every single feed.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.