Autoblog is not fetching the featured image

Autoblog is processing the feed but not fetching the featured images. I have selected "Use media:thumbnail tag of a feed item". But the Featured images are not fetching. The images in the contents are fetched.
The only difference in them is the content images urls were in https and the featured images were in http protocol. I have changed the featured image urls to https in the feed but still the featured images are not fetched.

  • Nithin

    Hi hkpinguin,

    Hope you are doing good today. :slight_smile:

    Please note that Autoblog is more of a RSS feed reader, and it can only pull what is in the feed, its won't be pulling anything directly from posts. I tested this further via the plugin side, and could notice anomalies regarding this.

    This looks more like an issue with how the feeds are structured, I'm checking with the developer to see whether there is anything specific that could be done in the plugin side to help resolve this.

    Will keep you posted via this ticket, once we get an update regarding this from the developer asap. Have a great day ahead. :slight_smile:

    Best Regards,
    Nithin

  • hkpinguin

    Sorry I didn't get it. The featured image was in the feed under the media:thumbnail tag and the add on for featured image should be capable to get it, otherwise, what is the purpose of using the add on "Featured Image Import"? After enable, it allow me to "Select a way to import featured image" and I choosen the one "Use media:thumbnail tag of a feed item" and the feed contains images URL in media:thumbnail tag, it simply can't grab it.
    Anyway, is there any update? Thanks.

  • Nithin

    Hi hkpinguin,

    Hope you are doing good today. :slight_smile:

    The featured image was in the feed under the media:thumbnail tag and the add on for featured image should be capable to get it, otherwise, what is the purpose of using the add on "Featured Image Import"?

    Sorry for the delay in getting back to you, we tested further via the RSS feed, but could notice the same issue.

    If I try to open the image listed in the media:thumbnail tag directly via the browser, it's throwing the following error:

    Missing Key-Pair-Id query parameter or cookie value

    https://my-cdn.h-oi.com/wp-content/uploads/sites/7/2018/09/HMTX-cover-150x150.jpg
    https://my-cdn.h-oi.com/wp-content/uploads/sites/7/2018/09/Apparel-2018-Q2-150x150.jpg

    That could be the reason for the the images aren't getting recognised when tested. Could I know is that how the images load in your side, when you open the image directly? If yes, that could be the reason behind the images not getting imported.

    Do you have control over your feeds, if yes, is there any way to update those links?

    Please let us know further about it, so that we could help get this sorted asap.

    Regards,
    Nithin

  • hkpinguin

    This issue already have been discussed with you support team a few times, please check back the conversation history. The images are protected so it CAN'T access publicly but it CAN access after login so there is no problem on the images. If it is the problem, why the images inside the normal blog body are ABLE to grab from the source!! What is the difference between message content and featured image? They are also protected under the same CDN domain, so why image in content is working but featured image cannot!! Have you ever try the URL in blog content, which is working, before asking? Did you go through all the conversation in live chat before repeating to ask the same question? I am tried to recap everythings every time to every different support agents again and again and again for the same finding.

  • Nithin

    Hi hkpinguin,

    Sorry for any confusion regrading this, if the images are working fine when it's logged in via the application. Then could you please share the login credentials of your application, so that we could test this further? We can only tell better, why it isn't working if we could test extensively, and replicate the same behaviour in our side when logged into the application.

    Without logging in, the images are always appearing private in our test, so it's tough to say what exactly is causing this issue specifically for featured images, and also check further with the developer for feedback.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -Application login credentials
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi hkpinguin,

    I'm attaching a patch below. Could you please try the following patch in Autoblog plugin, and see whether it works fine? You can replace the file cacheandfeatureimages.php shared in the patch, to the following path:

    /wp-content/plugins/autoblog/autoblogincludes/addons/

    Once the patch is applied, you should be noticing a new option as seen in the following screenshot:

    Please select "Use media:content tag of a feed item, and check whether the newly imported posts works.

    If you still have same issue, I'm afraid, it's pretty tough to say what's causing the issue without having access to your application side, and giving a closer look at it, so that we could see what could be causing the issue.

    Please let us know how that goes, have a great day ahead. :slight_smile:

    Best Regards,
    Nithin

  • Nithin

    Hi hkpinguin,

    I'm sorry, at the moment, we only offer support via Live Chats, and Support Forums. If there is any login credentials you think you could share, maybe steps to log into the private app etc, then that would help us in troubleshooting this further, so I could also bring into the developers attention, if needed.

    You can send the credentials the same way as mentioned in last reply:
    https://premium.wpmudev.org/forums/topic/autoblog-is-not-fetching-the-featured-image#post-1358806

    Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.