Autoblog "Next Check" times have turned red...

I've been trying to get the Autoblog plugin in to cooperate with another plugin and one of the methods I tried was changing the time zone of my blog. I guess by default they are set to GMT =0 and I changed it to my appropriate time zone of GMT -5 (EST). That affected both columns (Last Processed and Next Check) by turning all the times to the accurate time (GMT -5) but turned them all red. Then I clicked the Debug button (the add-on option), don't know if that was the right thing to do, but it got rid of the red text in the "Last Processed" column, but left the Next Check column red.

What do the red times mean and if I need to make any additional changes? Please advise.

Thanks,
James

  • jnholt3

    To give another update, when I change the process times to "every day", it sets the next time in regular gray, and looks like it will work. But if I change the process time to any other setting (every five hours, every hour, etc.) it lists the next process time in red. Also, when I click the debugging option, it resets all the next process times for five hours from now (except for the feeds I had already set to check "every day"), but they are still in red.

    Changing the time zone in general settings has clearly affected the plugin.

    Hope this helps,

    James

  • aecnu

    Greetings James,

    I personally have not seen the red dates in our production server running the Autoblog plugin, but i am sure this is not a good sign and at the same time certainly not ominous.

    In an effort to find out what is going on, if you have not already could you please turn on the debug mode --> Autoblog --> Options --> Enable debug mode and also run an Autoblog repair through one time to see if that straighten things out --> Autoblog --> Repair Autoblog --> Repair Now

    If this red time thing has still not straightened out please try running a manual processing of the feed(s).
    Autoblog --> All Feeds --> check relative feeds and choose to Process Selected.

    I await to hear from you on how all this went and if we have indeed resolved the issue.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings James,

    In an unrelated to this plugin issue, but definitely related to the time changes, what time is your server set at?

    In addition, can you please set the time back to GMT=0 to see if this sets everything straight for a day or two?

    Please let me know the results due to I am trying to figure out how much of a relationship there is between the server time zone and a set time zone in a plugin and this info could prove very valuable in figuring this all out.

    Cheers, Joe :slight_smile:

  • jnholt3

    Hey Joe,

    Thanks for the reply.

    1) Changing the time zone of the blog back to UTC +0 (the original setting) did fix the autoblog plugin. So that's definitely positive.

    2) The server is set to GMT -5 (Eastern Time Zone) which coincidentally is my time zone and what I tried to change the blog to.

    3) The main reason I changed the time zone to begin with was to see if having the default (and inaccurate) time zone was causing a conflict for another plugin that is supposed to be grabbing the posts made by the WPMU autoblog plugin and syndicating those posts to some bookmarking sites. It could be the server time zone vs. blog time zone differential is causing an issue with the "other" plugin, but I'm not sure at all.

    Hopefully, the autoblog plugin can be fixed to work on the same time zone as the server just so I can eliminate that as the problem for the "other" plugin developers, who are trying to also figure it out.

  • jnholt3

    Okay, so my network admin WP install (v. 3.3.1) doesn't have a general settings tab, just a "Network Settings" and "Network Setup" and neither have any time or time zone settings. So, I went into Cpanel->Softaculous (which is the wordpress installer) and clicked on the blog settings and at the bottom of the page it says : "All times are GMT. The time now is March 1, 2012, 9:29 pm."

    So, that's the only place I know to find what looks like the network time. If there is another location to look, just let me know.

    To me, it appears the server time zone is GMT -5, network time zone is GMT +0, and blog is currently set to GMT +0. Which would make sense, seeing that I never updated the time zone until just a few days ago and I would assume that the blog install would just use the network time zone as the default.

    Cheers!

  • jnholt3

    In case I'm not understanding what you're asking for, I'm going to use some examples.

    The site that I've been working on is http://adult.toysblog.co. It obviously has been reset to GMT+0. I just checked the time zone of the install url, http://toysblog.co and it is also set to GMT+0. I'm guessing that's what you're referring to by "networks main site".

    Please let me know if I'm wrong.

    Thanks,
    James

  • aecnu

    Greetings James,

    You are right on the money --> it is my opinion the time zone problem is negated by having synchronized time zones between the three entities:

    Server
    MultiSite install
    Site time zone

    If you have root access to your server, while you are logged in via ssh simply type in date and you get something like: Thu Mar 1 19:14:42 EST 2012

    In my case I set my servers to say the time in Eastern Standard Time zone as indicated above.

    Is everything working as expected now?

    Cheers, Joe :slight_smile:

  • jnholt3

    Hey Joe,

    Okay, the server was already set to UTC -5, so I changed both the install domain and site time zone to UTC -5.

    That turned the autoblog feeds back to red. I then left the install domain at UTC -5 and changed the site time zone back to UTC +0 and the feeds are back to gray and functioning normally.

    Which leads me to believe that the synchronicity isn't important, but that once the autoblog plugin is activated on a particular time zone setting, it can't be changed. Which to me seems like a coding issue. Just thinking out loud, I would imagine the functionality to handle time zone setting changes was very low for the coders, if it was even thought about at all since once the plugin is working on a particular schedule, not many people have the need to change the time zone settings.

    Let me know if you would like to login to any of my wordpress, cpanel, etc.

  • aecnu

    Greetings James,

    Thank you for the additional feedback you have given to me which has turned on an additional light in my head and another possibility of resolution.

    Though I agree that it must be locking on to the time zone of the date of activation, this may be in a way a good thing in the reverse thinking of that the zones were all set correctly from the beginning and for example the server clock went haywire etc.

    Now the big question here now is how to change that original time zone setting within the Autoblog data.

    I have poured through the database and could not find where the possible entry may be.

    Now it is time to call in the lead developer for assistance and to possibly find out where Autoblog is storing it's time zone/time reference information.

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings James,

    Considering all that we have done together you an I, there is one thing that has just became obvious that we have not done - and that is to set the time zone where you want it - then delete a feed and re-enter it to see if it indeed turns to grey and runs - if it works it means that the time zone is locked in with the creation of the feed which would then indicate that the feeds just need to be re-entered to be re-synched with the new time zone selection.

    Realistically I cannot blame this issue on the plugin, the time zone should have been set correctly from the beginning, though that is now a mute point. If this is indeed the case, the plugin instructions should clearly indicate that this should be one of the first steps to perform i.e. setting up the time zone - which it clearly does not mention to date.

    However, though it is a monumental task, all the documents for all the plugins are being re-written as a recent benefit of the support team being more then doubled in personnel in the last couple of weeks.

    Please advise if I am correct about setting the time zone and then deleting and re-inputting the feed information does indeed solve the issue.

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings James,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.