[Autoblog] No Featured Images imported by AutoBlog

I'm testing the following feeds (all of which VALIDATE)--
http://rss.cnn.com/rss/edition.rss
http://feeds.feedburner.com/TechCrunch/
http://thehill.com/rss/syndicator/19110

AutoBlog plugin is successfully pulling in text content, but failing to find and assign a "Featured Image". In fact, it doesn't pull any images, even if I turn on that Option. But I don't need all images, just need "Featured Image" option to work. Thnx.

  • Adam Czajczyk

    Hello @@richard_gardella!

    I hope you're well today and thank you for your question!

    Whether the Autoblog can fetch a featured image from the feed or not depends mostly on a feed construction.

    I have checked these three feeds then.

    http://rss.cnn.com/rss/edition.rss

    This feed does include images but is not putting them in content and is not using media:thumbnail or enclosure tags that are by default handled by SimplePie library built into WordPress. That's the library that's also used by Autoblog for fetching RSS feeds. I have asked our developers if there's any way to add support for "meda:content" tag that's used in this feed.

    http://feeds.feedburner.com/TechCrunch/

    This feed includes images in item content so in "Featured Image Importing" section of feed configuration in Autoblog for this particular feed, please set either "Fine the first image within content of a feed item" or the "Find the last image within content of a feed item" option.

    http://thehill.com/rss/syndicator/19110

    In this case there seems to be no images included in feed at all. Please note that Autoblog can only import and use what is included in a feed. It cannot take content directly from the site that feed links to, so it won't "scrap" the content of an original article for media or anything else.

    That said, please keep an eye on this thread for further information about option to handle "media:content" tag as mentioned in relation to the second feed above. If there's a way to add it, we'll let you know here.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello richard_gardella

    I hope you're well today and I'm sorry for keeping you waiting.

    Fixing the issue requires changes in plugins code. I have attached a .zip file containing "hot patch" to this thread that I tested with the CNN RSS feed (from your original post) and it's working fine with it.

    In order to apply the patch, please follow these steps:

    1. download an attached "autoblog-patch.zip" file and extract it to your local drive
    2. access your server (your site's WP install) using FTP or cPanel's "File Manager" tool
    3. upload the

    "cacheandfeatureimages.php"

    file from inside provided .zip file to this folder of your site on the server

    /wp-content/plugins/autoblog/autoblogincludes/addons/

    The file from inside .zip archive should overwrite the one that exists on the server.

    4. Once this is done, go back to your site's dashboard and edit feed settings; You should see a new option in the "Featured Image Importing" section of feed configuration:

    "Use media:content tag of a feed item"

    Select this option and save feed configuration.

    From now on, new items from that feed should be adding the featured image properly.

    I have also forwarded this proposed patch to Autoblog developers so they could include it in the plugin, though please note that I'm not able to give you an ETA on the release.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.