Autoblog not auto processing

Like some others have reported, I too am having trouble getting Autoblog to auto process the feeds. If I manually process the feed it works just fine. I have installed this plugin now on two separate sites both pointing to different feeds and have the exact same problem. Do I need to setup a cron or something server side to get these to process?

Thanks,

Ken

  • DavidM
    • DEV MAN’s Mascot

    Hiya Ken and first off, welcome to WPMU DEV!

    Autoblog would require a bit of traffic for the processing to occur (just like the standard WordPress cron). Are you receiving traffic or are you frequenting the site enough that it would process as such?

    -David

  • DavidM
    • DEV MAN’s Mascot

    Hmm, that seems like a sufficient number of hits to trigger the process, not sure why that's not occurring. I'll flag a few of the guys over here who may have come across this one.

    To help though, could you let us know what versions of WordPress and Autoblog you're using?

    Also, from what I recall, it uses its own method for the scheduling of the process, so there's not a way to trigger it manually. At least as I recall. I'll tag one of the developers here as well.

    Thanks,
    David

  • Timothy Bowers
    • Chief Pigeon

    Hey krwsolutions.

    Can I check what version of WordPress and AutoBlog are you running?

    When you click process does it manually process then?

    How does it function when all other plugins are deactivated and your using the default Twenty Eleven themes? Just wondering if there is a conflict there....

    Could you please take a look at your servers error logs and let us know if there are any errors there?

    Let us know. :slight_smile:

  • krwsolutions
    • New Recruit

    Everything works except for the scheduling. I've tested in a clean install with just autoblog and have the same problem. WordPress 3.3.1 and AutoBlog 3.6.2. There are no errors in the apache error log. I also tried turning on debugging within the plugin and nothing was written to the log.

  • Timothy Bowers
    • Chief Pigeon

    Hey again.

    Can you crack open your wp-config.php file and stick these in there:

    define( 'AUTOBLOG_PROCESSING_TIMELIMIT', 20);
    define( 'AUTOBLOG_FORCE_PROCESS_ALL', true);

    Pop em under the the "WP_DEBUG" option.

    Then try again. If 20 seconds isn't enough then stick it to 40, Even try something silly like 10 minutes and give it time to process the feed for you.

    Let me know how that goes.

    Take care.

  • valu
    • Design Lord, Child of Thor

    I'm facing exactly same problem than krwsolutions with WordPress 3.3.1 and Autoblog 3.6.2. I've tried to solve problem with Autoblog Repair Feeds plugin, but it didn't helped.

    Any other solutions than constants in wp-config.php?

  • krwsolutions
    • New Recruit

    Hello,

    Sorry for the delayed reply, I've been out sick. This is the first chance I've had to reply.

    I tried adding the two lines:

    define( 'AUTOBLOG_PROCESSING_TIMELIMIT', 20);
    define( 'AUTOBLOG_FORCE_PROCESS_ALL', true);

    This didn't fix the problem. I waited hours and it never processed the feed. What's next?

  • krwsolutions
    • New Recruit

    Hi Guys,

    I've been REALLY sick and haven't had time to play with this until now. I have yet to get this to work correctly. As is, the plugin is 100% worthless. Is there a URL that can be called by cron job that will execute the process command? This would solve the problem instantly.

    Thanks,

    Ken

  • krwsolutions
    • New Recruit

    Did some more digging... if autoblog is using the built in WP Cron, shouldn't there be an entry in here for it? (See attached screen shot.) I used Debug Bar and Debug Bar Cron to inspect the WP Cron and here's what I found (or rather didn't find.)

  • familylives
    • New Recruit

    Not sure if this is related to the new version but I can't get any feeds to process on a clean install with Autoblog... feed is fine, feed details are in the DB but when you press manual process it says processed but no import happens.

    In debug mode it says "no problems" been through the forums can't see any mention of this issue so thought I would flag it as possibly related to this new update..

    Running latest wordpress and all plugins are upto date.

  • rustynations
    • WPMU DEV Initiate

    I have a similar problem...

    All the feeds will manually process.

    "What's in Cron?" is showing the autoblog_process_feeds every 10 mins.

    I've added the lines to wp-config:

    define( 'AUTOBLOG_PROCESSING_TIMELIMIT', 20);
    define( 'AUTOBLOG_FORCE_PROCESS_ALL', true);

    Wordpress 3.3.2
    AutoBlog 3.7

    I can manually process feeds. So the "Blog" part of AutoBlog is working fine... just not the "Auto" part... :slight_smile:

    I also have WP-Cron Control installed so that I can load a specific URL to fire the cron jobs manually... that doesn't work either.

  • Mason
    • DEV MAN’s Sidekick

    Hiya rustynations,

    I've just asked the developer for continued feedback. I haven't been able to sort this, but it seems to be working for some but not others. Are you getting anything in your PHP error logs?

    Thanks for the detailed feedback!

  • Mason
    • DEV MAN’s Sidekick

    Ok, the dev had a sick day today.

    (Yea, good coding... bummer we're not closer to tracking it down though!). I'll ask Barry to take a look first thing when he comes back online.

    Thanks for checking and your patience as we get this sorted.

  • Mark de Scande
    • Syntax Hero

    Some testing from my side aka BlogLines.co.za

    1) Network activate the plug so i could see what sites was using the Auto Blog
    2) Change the names of the feeds so i can see what url they are posting to:
    IE From superblogs.co.za To patent.bloglines.co.za @barry it would have been nice to see the Feed target as a url in network wide mode :slight_smile:
    3) Made sure CSF Fire Wall was not blocking the feeding sites Ie Pulling posts from superblogs.co.za to patent.bloglines.co.za it all works fine
    4) PHP times :slight_smile: memory_limit 256 / max_execution_time 3140 / max_input_time 3140
    5) Some times i do get time outs "Operation timed out after 25000 milliseconds with 0 bytes received" This "bug" i only started seeing with the new WordPress 3.3.2 alsow get the same err when adding new images to and site on BlogLines.co.za but not every time so i will have to say it is a WordPress BUG.
    6) Also Running http://wordpress.org/extend/plugins/wp-cron-control/
    7) wp-config.php define('DISABLE_WP_CRON', true);

    Still can get auto blog to auto post i have a idea will implement it now and will update you guys :slight_smile:

  • Mark de Scande
    • Syntax Hero

    Yes it turns off cron :slight_smile:

    PS cron is a server killer

    The i turn it back on with http://wordpress.org/extend/plugins/wp-cron-control/ this will over ride the setting in wp-config

    I have now set up a cron job for one of my sites too test Auto Blog

    http://superblogs.bloglines.co.za 92631a9d09166527ee7a994de513a421 >/dev/null 2>&1

    So the cron job will run only for that site every 30 Minutes

    I will update you as soon as i know it works.

    @Barry this AutoBlog use to work fine with all the settings the way they were but it looks like you guys had added 2 things

    1) Customers must go to the site Ie Web Traffic
    2) Cron Will only fire if there were traffic

    So that means AutoBlog will only work if there is a cron job in place to fire cron and if there are customers on that site..

  • Mark de Scande
    • Syntax Hero

    Just did a test

    1) remove wp-config.php define('DISABLE_WP_CRON', true);
    2) remove define( 'WP_CRON_CONTROL_SECRET', 'blabla' );
    3) remove WP-Cron Control

    Had a look at the server load from 1 - 7 load it jumped to 30 then to 60 (WordPress sort out your cron)

    I have added a screen shot just to show you guy CRON is a server killer

    I then turned all the stuff back on and the server is back to 1 - 7 :slight_smile:

  • Barry
    • DEV MAN’s Mascot

    1) Customers must go to the site Ie Web Traffic
    2) Cron Will only fire if there were traffic

    Autoblog has always been reliant on there being web traffic. The previous versions of the plugin (before we moved to cron) used a custom scheduler which was called on every page load via the init action (it didn't run on every page load, just checked whether it should and did if it was its scheduled time).

    Whilst this was fine for bringing in a few posts from a few feeds, we had to limit the processing to a few seconds as any longer and it would cause a noticeable slow down of your sites loading. This method also limited what we could have the plugin do - and pretty much prevented us from implementing one of the most requested features - importing images as well as posts.

    We released the image import functionality in the last version, as we no longer had to worry about slowing web page loads down.

  • Mark de Scande
    • Syntax Hero

    @barry thank you for the feed back so lets recap if you want to run AutoBlog on WordPress Multi Site and you have cron disabled then do the following

    1) Install Auto Blog and network activate
    2) Go add your feeds to the sites you want
    3) set up cron jobs for the feed site set it at about 15-30 Minutes
    4) open a new browser and then go have a look at the feed site
    5) open the feed site and you should see the new posts that have pulled in

    So recap if you disable WordPress Cron then auto blog wont work if you dont do step 1 - 5

    So i no longer just works :slight_frown: sad it use to be perfect.

    I hope this post helps some one out there so you guys dont have to sit like me and test it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.