Autoblog not populating the RSS feed on subdomain

Hi I just provided your team access via my WPMU Dev dashboard. There is a question about using the autoblog on a specific subdomain, and I left the details there. I was unsure how to go about requesting support for this, or if providing you access was enough since this is the first time I had to do it. Thanks.

  • Kasia Swiderska
    • Support nomad

    Hello Jeff,

    Please post full questions in thread - support access is time limited and if is expires then next staff member that checks that thread will have no clue about thread details. I'm re posting then your question here:

    We are trying to add the autoblog option to this subdomain listed below, but the feed will not populate. I searched support forums and tried out some of your proposed solutions, including activating some of the add ons, but it's still not working. He has this domain mapped with the 3rd party MU mapping plugin. If this makes it hard for you to access the subdomain please let me know.

    I tried to check that subsite, but I could not - there was login form - so I wasn't able to check what feed are you adding there.
    Please leave in support message rss feed you want to add to Autoblog on that subdomain and if possible credentials to access that subsite, so we can test feed and check settings on that subsite.

    kind regards,
    Kasia

  • Jeff
    • Design Lord, Child of Thor

    Hi Kasia it's been several days with no response from you team. Am I posting in the right place about this? You should have all the info you need at this point to login. What else do you need from me in order to get this resolved? Thanks.

  • Kasia Swiderska
    • Support nomad

    Hello Jeff,

    I'm sorry for delay here - we process out thread from older to newer and our system prevents threads from bumping, so each new post is treated as new answer and is pushed down to the queue.

    Thank you for leaving credentials - I tested that feed on my site and despite different combinations of add-ons for forcing feeds I was only able to import only one post from that feed.

    There is no error in Autoblog dashboard nor in debug.log that would point me to why this feed does not work.
    I tested another feed and it was processed correctly.

    In this case I'm pinging our developer for valuable feedback why this particular feed is not working as should. As soon I'll get a feedback from dev I'll update thread.

    kind regards,
    Kasia

  • Kasia Swiderska
    • Support nomad

    Hello Jeff,

    I spoke with developer and he suggests adding this line to wp-config.php file

    define( 'AUTOBLOG_PROCESSING_METHOD', 'pageload' );

    before line /* That's all, stop editing! Happy blogging. */

    and then again process the feed. Let me know if this will work for you.

    kind regards,
    Kasia

  • Nithin
    • Support Wizard

    Hi Jeff,

    Hope you are doing good today. :slight_smile:

    I checked this in my system, and the plugin seems to grab only one post, this could be more related to the feeds you are using. I'm pinging the developer regarding this issue, and will keep you posted once I get an update on why the feeds aren't being recognized.

    Kind Regards,
    Nithin

  • Jeff
    • Design Lord, Child of Thor

    Thanks Nithin. Yes, Kasia confirmed earlier that it only populates 1 post and then we tried adding the define( 'AUTOBLOG_PROCESSING_METHOD', 'pageload' ); command to the wp-config file which didn't fix the issue. I appreciate you looking into this further.

  • Rupok
    • Support Ninja

    Hi Jeff,

    Thanks for confirming. I found that Nithin has already pinged our developer regarding this and our developer is still checking this. I've also pinged our developer and requested him to facilitate the process. I believe, he will come up with his valuable feedback soon.

    We will update you here as soon as we get something from our developer. I appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Jeff,

    Just got an update from our developer.

    Can you please try adding the following line in your "wp-config.php" file?
    define( 'AUTOBLOG_POST_DUPLICATE_CHECK', 'guid' );
    I believe, this will help.

    Please let us know if it doesn't. We will be glad to investigate further and will try to resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Jeff
    • Design Lord, Child of Thor

    Yes that worked! However only the last 10 posts were added (we were trying to do more).

    I'm not as concerned about that if it continues to update with the newest content moving forward.

    Any thoughts on why just 10 were added? Thanks again.

  • Rupok
    • Support Ninja

    Hi Jeff,

    Any thoughts on why just 10 were added?

    Thanks for asking. I just checked your source RSS feed and found that there are 10 posts listed. That's why autoblog added 10 posts (all found on that RSS page).

    I'm not as concerned about that if it continues to update with the newest content moving forward

    To make autoblog keep posting latest posts, you have to set a schedule. To set the schedule, please go to "Dashboard > Autoblog > All-feeds" section. Scroll down till the "Feed Processing" section. There, please set the interval in "Process this feed" option. Please check the attached screenshot for reference.

    Then save the settings.

    This will make Autoblog process the feed continuously with the interval you have set and that will make autoblog import all new posts from your feed automatically.

    I believe, these helped. Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.