Autoblog not processing on subsites

So I replace the previous work press feeds burner which worked for this autoblog but now it appears i was to hasty.

The autoblog does not seem to be processing my feeds except manually.

See: http://screencast.com/t/a7OiTd09

  • Timothy Bowers
    • Chief Pigeon

    Hey Jason, hows you?

    Can you crack open your wp-config.php file and stick these in there:

    define( 'AUTOBLOG_PROCESSING_TIMELIMIT', 20);
    define( 'AUTOBLOG_FORCE_PROCESS_ALL', true);

    Pop em under the the "WP_DEBUG" option.

    Then try again. If 20 seconds isn't enough then stick it to 40, Even try something silly like 10 minutes and give it time to process the feed for you.

    Let me know how that goes.

    Take care.

  • aecnu
    • WP Unicorn

    Greetings Jason,

    Thank you for being a WPMU Dev member!

    Please clarify the following statement:

    So I replace the previous work press feeds burner which worked for this autoblog but now it appears i was to hasty.

    Please advise what you meant by this. In addition, did it work fine before the replacement?

    Cheers, Joe :slight_smile:

  • Jason
    • The Bug Hunter

    hmmm, the reason I continue to be a premium member is because our support guys (most of them :wink: ) are awesome.

    You can make demands or be frustrated a little and they are professional enough to deal with it.

    However, I would love to see this company reach the level where you plugins work and not to loaded and heavy on the server. I like the concepts of add-ons on needed only services.

    But back to the point of working plugins. When we sometimes compare FREE plugins with some of what you guys offer... At times it is easier just to go with the FREE plugin as they seem to work right out of the box.

    In fact, when I read the promo for them it makes me smile....

    Autoblog

    This plugin automatically posts content from RSS feeds to different blogs on your WordPress Multisite network, it's like feedpress or wp-o-matic, except that it actually works, brilliantly and simply!

    Tim, you are ever so helpful and thanks for the fix, but I this is extra work if I have several networks esp when most other similiar paid and FREE plugins does all of this for you.

    I am a big believer in WPMUDEV but hope your programmers make plugins that works all the time on time :wink:

    Have a great weekend.

  • Jason
    • The Bug Hunter

    ps @Tim I don't want to abusae the server loads and get complaints. I know the previous plugin had options for dealing with that. Would the proposed solution work? What is advisable?

    PS. can we expect a more solid fix in the future?

  • Timothy Bowers
    • Chief Pigeon

    Hey Jason.

    Its not a bug, its a way to control the plugin so it doesn't keep processing until your resources are used up.

    The other plugin you refer to may have had settings stored in the DB for this, or just didn't have a way at all? Not sure without testing it.

    Its possible to add an option to the settings page I suppose, but thats just another item to pull from the database and check for. Its more efficient to define a constant like this.

    I will of course provide feedback on this for you. :slight_smile:

    Take care.

  • johnpent
    • Flash Drive

    Hi, I am having the same issue. I tried the code as suggested:

    define( 'AUTOBLOG_PROCESSING_TIMELIMIT', 20);
    define( 'AUTOBLOG_FORCE_PROCESS_ALL', true);

    I am pulling from my another one of my sites rss feeds, and the manual "process selected" always works fine. Additionally - it aways shows "next check" in the past when it missed a auto process.

    Is there a cron command or something else I should have set up? I looked and looked and did not see it for this. I like this because it does not create 19 revision versions of one post like the infamous feedwordpress does.

    You guys do great work and give great support. I appreciate that.

    Thanks,

    John

  • Jason
    • The Bug Hunter

    that was my reason for swriching from feedwordpress which is not bad but buggy.

    @John, what interval of time you have it set too? I change mine from every 5hrs to every 1hr and then it seems to work.

    That is not a fix but maybe something u can try

  • johnpent
    • Flash Drive

    I have it at 120 seconds in the above settings, then every 30 minutes on one feed.

    I am still having to pull in manually.
    Feedwordpress always works. My problem is that it as it creates so many revisions a large multisite group db grows too big.

  • aecnu
    • WP Unicorn

    Greetings Jason and John,

    Gentlemen where are we on your Autoblog issues?

    We have not heard from either of you in quite some time.

    Did you get this resolved yourselves? By us? In live chat?

    If so no need to reply - Happy Days!

    For now I am going to mark this ticket as resolved. However, if either of you are still experiencing problems or have questions related to this thread please feel free to mark it below as not resolved with a check mark and give us an update to what is happening or not happening to include any errors.

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.