Autoblog Re-importing Deleted Posts

Autoblog Plugin

Of all the posts that are imported, I delete some and publish some. During the next import cycle the deleted ones get re-imported. Please suggest how to stop this from happening. Thanks.

  • Alexander

    Hey @ssguptainc, thanks for getting in touch about this.

    After you make the changes, do you let autoblog just handle it on a schedule? Or do you tell it to process the feed at that time. It could be as simple as a bit of cacheing going on. Perhaps even though the threads were deleted, they still showed up in the feed temporarily.
    Most of the time with Autoblog, it's easier to figure out if we have a closer look. Could you get me the feeds that you're having Autoblog pull from? If you'd rather not post them here you can email them to me here: https://premium.wpmudev.org/contact/

    Best regards,
    Alexander Rohmann

  • Alexander

    Ok I see what is happening. Because you are deleting the posts, when Autoblog reprocesses the feed, it thinks the post is new and recreates it. This is the intended design of the plugin, it helps make sure that sites stay in synch.

    You can get around this by not deleting the post after it is pulled in, and just publishing what you would like.

    Or, if you'd really like to delete them, another thing you can do is turn down the "Import the most recent X number of posts" setting for each feed. Because you're processing every hour, you can probably turn this down to maybe 1-3. That way it won't keep pulling in past duplicates.

    Let me know how it goes, and if this helps alleviate the problem

    Best regards,
    Alexander Rohmann

  • Alexander

    Hello again @ssguptainc,

    I'm just responding in hopes that I can clarify! I'm sorry about the confusion.

    If you tell Autoblog to only check for posts in the past hour, it won't constantly be pulling in the old posts that you deleted. This can be configured from your feed settings.

    The plugin uses the existing posts to know what has or has not been synched. So I don't see how that is faulty design.

    Hopefully this setting can help fix your problem. Let me know if you have any more questions.

  • A.B.King

    @ssguptainc, I am not a WPMUDEV staff. I'm just a user like yourself. The solution to your problem is pretty simple. I'm sure it would be quite satisfactory to you & to Alexander Rohmann ( the wpmudev employee you are angry at for being nice & polite ).
    @ssguptainc, After Autoblog imports all the feeds, mark the feeds you want to delete as "Drafts" do not delete them. Then when the owners of the site you are bootlegging content from add more posts to their site like 20 or 'x' amount of new posts, the old set of posts that include the feeds you don't like move out of the range of the fixed number of posts you set that particular RSS feed in Autoblog to import. Then you would be free to move into your Drafts folder and delete "ONLY" those old posts from that came from that RSS feed THAT NOW HAVE TWICE AS MUCH NEW POSTS than the number of posts you set that RSS Feed in Autoblog to import.

    HAPPY NOW!

    By the way, if you don't want to stress yourself too much and make everything super easy for you, Decrease the post import number for the RSS Feed in Autoblog (to maybe 15 or 10), and then increase the Autoblog frequency to be as frequent as possible (think the Top 3 or 4 most frequent frequency durations).

    Then every month or couple of weeks (depending on the frequency of new posts by the site owner or RSS Feed owner whose content you're bootlegging), go into your "Drafts" folder & delete ONLY drafts that are MORE THAN TWO WEEKS OR ONE MONTH OLD.

    PS: You Need To Lighten Up. Life Is Too Cool To Go Through It Angry.
    Be A Gentleman. Apologize To Alexander Rohmann.

    & Bootlegg Wisely.

    - Alfred Benjamin King.