Autoblog released!

Hi Guys,

We've released version 1.0 of Autoblog for WordPress MU!

https://premium.wpmudev.org/project/autoblog

Now, as well as twittering, posting and generally celebrating it all around (remember to use your affiliate link :slight_smile: I figured this would be a good thread for any Q&A, suggestions, bugs or support we can provide for it.

We're very much determined that this will be the no.1 most useful automatic blogging via RSS feed plugin available for WordPress MU, and your feedback and requests will help us get there.

So... looking forward to them :slight_smile:

Cheers, James

  • Ovidiu
    • Code Wrangler

    screenshots look great but I think one of the other plugins also had the option of creating new categories according to the original categories of the republished post. Is it maybe possible to implement this feature too?

    Besides, what about another option/checkbos to use the category of a post as tag?

  • James Farmer
    • CEO (of WPMU DEV, honest)

    @Ovidiu I think this does it if you decide to import the original tags and cats... but Barry can tell you more as it's his 'ting :slight_smile:

    @georgef this is completely different to feedwordpress, it allows site admin to populate blogs across the site at will, it's not for individual users to use.

    There's no reason you couldn't use the two in partnership though

  • Barry
    • DEV MAN’s Mascot

    @Ovidiu - RSS feeds send both the tags and categories as "categories", so rather than mess up the category lists, I decided to implement them as tags.

    So you can set a base list of tags, and then the system can add any tags/categories that are also in the feed to your system as tags.

    But if you know, or can point me to, a way to distinguish between them in the feed then let me know and I'll enable the category adding straight away.

    This is also a 1.0 release, so any feature requests, let us know.

  • Barry
    • DEV MAN’s Mascot

    @qlof - It uses a "global wp-cron", which is a similar method to the automessage plugin.

    Basically it hooks into the wp-cron list for each blog on your site (without actually adding itself to every blogs cron - it's rather neat if I do say so myself). This provides a more accurate method of firing wp-cron jobs as it isn't reliant on your main (or any other) blog receiving a relevant number of hits, instead it uses all the hits across your entire MU site.

  • heysailor
    • WPMU DEV Initiate

    Fantastic work, you've hit the nail on the head with this one as it's right what I needed.

    One query - how does it handle images in the feed? It'd be handy if it downloaded each image to the relevant site blog, and substituted the correct image url into the <img> tag.

    Cheers,

    Nick

  • Qlof
    • The Crimson Coder

    cafespain: thanks for the answer.

    I found a small bugg.

    When I've set the settings for a feed, blog and author it changes the author to "admin" as the back-up author if the feeds author can not be used. When I originally started the feed, I had selected author1.

    When trying to set it back to author1, the user isn't in the list. i believe that the only users in the dropdown list are users of the main blog.

  • Barry
    • DEV MAN’s Mascot

    Hi @qlof

    Can you try changing the blog to add the posts to, and then change it back. It should reload the the authors list based on the blog selected in the top section. It uses an Ajax javascript call to do this, so can you let me know of any errors you get and / or make sure that the js directory is loaded correctly to your server.

  • Barry
    • DEV MAN’s Mascot

    At the moment it will load the images from the original location. Importing the images locally and modifying them was / is on my list of desired features.

    So if I can work out a neat way of accomplishing it, I'll definitely work on adding it in for a later version.

  • Qlof
    • The Crimson Coder

    I know it shouldn't be, but could it be an issue with google chrome? Every time I go change it to the blog and author that I want it changes it back to "Use feed author" and backup author "admin". When I changed it to an other user on the main blog, that stuck. So it shouldn't be something with my sql tables.

  • John Keegan
    • WPMU DEV Initiate

    When we have this new Autoblog installed, creating new blogs from the control panel fails, the error seen at the URL of the new blog is "The blog you have requested is not installed properly. Please contact the system administrator."

    In mysql we see that the blog's tables do not get created. This is on a stock wpmu 2.8.4a install with buddypress trunk. Autoblog is the ONLY plugin and removing the plugin immediately solves the issue, new blogs are created properly. ..

  • heysailor
    • WPMU DEV Initiate

    Mmm, I'm having the same problem as johnkeegan - installed as per instructions on local test site (WPMU + Buddypress + multiple plugins) and have set up a few feeds which previously worked with feedwordpress and Autoblogged - but there's nothing happening: no posts being created, despite plenty of site activity.

    Where could I start to prod it into action? Config is great, nice and simple and easy, well done, with heaps of options. Just need it to kick into life!

    :slight_smile: N

  • tim@trollans.ca
    • Flash Drive

    I think I am doing it right. I am assuming that the parsing period means the feed processing time? I have it set to 5 minutes. For the feed url I am using http://trollans.ca/portfolio/feed/ There is one post in the blog where autoblog is directed, not sure if that is effecting it. Am I right in assuming that the new posts should populate the post area?

    Does it just bring in new posts, or does it import all the posts, i.e. older posts show as weill? Hopet that makes sense.

    I am sure once I get it working, it is going to be fantasitc! Just feel either I am missing something. Also, I am just coming from inside my own wordpress mu site. Assume it works for all RSS feeds?

  • Barry
    • DEV MAN’s Mascot

    It is entirely dependent on your wp-cron process firing, so initially I would suggest waiting for a bit and seeing if it starts up.

    I will post a "tweak" so that you can manually run the process from the admin panel, to make sure that it is bringing in the feeds correctly, and also see if I can add it as one of the buttons on the admin page.

  • tim@trollans.ca
    • Flash Drive

    Thanks.

    Can you explain the wp-cron firing to us a bit. I am assuming that means activity? I am just running a couple of posts to see if it imports. Sorry, I am still learning.

    Am I right on the assumption of the feed url being like: http://trollans.ca/portfolio/feed/ ?

    And if possible, should it pull in the whole blog like rss does, or only new posts?

    Once again, thanks in advance, it really does seem like an awesome plugin and it does look like it will be very easy to use ... once I figure it out. :slight_smile:

  • Barry
    • DEV MAN’s Mascot

    Wp-cron is wordpress's method of automating some jobs and tasks without the need for a user to setup a server side cron job.

    Basically every time a page is loaded in WP a background page is loaded which loads a list of scheduled jobs and checks if any are due to be run, runs them, and then re-schedules those that aren't one time runs.

    Plugins can hook into this as well to schedule their own processes.

    Because it is reliant on a page being loaded on your server, the reliability of the schedules are often a bit "off". If your site gets two visits a day, then your jobs are only going to be run on each of those visits (so maybe 12 hours apart, even if you have something that you want to run every 5 minutes).

    Autoblog and automessage plugins use a custom modification that creates a "global" cron job that will be run on all page loads on all blogs across your site. This helps to improve the timing of their jobs as there are more page loads to use for the scheduling.

    If you don't think your site has enough traffic, and you have access to it, you can schedule a server crontab (linux) to fire the wp-cron.php file on a more regular basis. I'll see if I can find a useful article on how to do that and post the link here.

  • tim@trollans.ca
    • Flash Drive

    That's what I figured, so now if I can just get it pulling in I will be laughing. I am not sure how, but I still feel I must be missing something that is stopping it from working. I don't want to try to find a work around because this plug-in will be amazing! It definitely has everything and more that one could want.

    I've tried loading pages from several computers over a few days and still do not get anything. If I could just get something to confirm the settings or something would be nice.

  • svteg
    • Flash Drive

    I just installed this plugin, two questions:

    I can't edit the feed options after I installed and activated it for a blog. I can't click on the feed in the admin panel, I can only delete it, is that right?

    I installed a test feed, it published 4 posts, and 10 post swere scheduled. Is this a wordpress setting or a feed setting where I get the feed from? I can't publish them from the backend.

  • svteg
    • Flash Drive

    Forget my first question, something went wrong with uploading the includes

    Edit: Well, there is still something wrong. When I choose for Add new, the box opens, but after a few seconds it closes again. So I have no time to fill in the title and the feed url. It's impossible to add a new feed.

    Edit 2: Ok, the problem is, when I click on Add new, the box slides open and it tries to open the whole form, after a few seconds it stops loading and the box closes again. The form is opened till "Add posts to" Internet Explorer says there are errors on the page. When I delete my first feed, so there is nothing in it, the form does open. But after one feed it is impossible to add another feed. Tested in Firefox and Internet Explorer

  • svteg
    • Flash Drive

    I activated autoblog on a fresh wpmu install and it works fine, so I guess autoblog has a conflict with another plugin. Anyone an idea to solve this, besides turning all the other plugins off (I need those plugins)

    I'm using:

    MU tags
    Ad sharing
    Global header
    login image
    send email
    tos
    tips
    messages
    google analytics

  • Barry
    • DEV MAN’s Mascot

    I'm going to add a "force process now" button for each feed so that you can run an initial import and check that the feed is working correctly straight away.

    In the meantime you can get things started by opening up the autoblog.php file and scrolling down to line 818 and uncomment that line.

    The next time you click on the autoblog panel in site admin, it will take a little longer to load (patience) but will enforce a run of the feed processing so you can check the content is coming through and the feed is actually working.

    If that works fine, then it's a wp-cron issue we need to get to grips with... :slight_smile:

  • tim@trollans.ca
    • Flash Drive

    I have done that. :slight_smile: I have also tried to uninstall it and reinstall it again to no avial. For this last test, I uncommented the line, loaded and tested it and then brought the file back from the sever to make sure that I was actually using the modified verision.

    Does it store something in a table maybe? Anything I can do to help solve this for sure I will do.

  • tim@trollans.ca
    • Flash Drive

    Here is an update. I decided to attempt to bring in another feed, so I used http://community.worldphysique.com/forum/categories/world-physique-magazine/listForCategory?feed=yes&xn_auth=no and guess what, it worked and worked the way I imagined it should! That said, when I use a feed from my site http://trollans.ca/portfolio/feed/ I get nothing. I know the feed is good because it rss's into facebook no problem.

    Hope this helps a bit. Any suggestions?

  • Barry
    • DEV MAN’s Mascot

    @svteg - It looks to be a javascript incompatibility. Can you try re-uploading the includes directory just to be sure.

    I've got some javascript changes made and I'm going to send through an update to Andrew as soon as possible. I want to try to get tim's issue sorted in the same update though.

  • tim@trollans.ca
    • Flash Drive

    Another update/clue? I noticed sometimes went I went to add a new feed, especially after one was already established that the page would have to reload numerous times before I could add the feed. Now I have just noticed that when I go to add a youtube video in a post (HTML), that the code disappears.

    My spidey sense is tingling and thinking that they may be inter-related. Video that was added previously, is still there and working fine.

  • tim@trollans.ca
    • Flash Drive

    And one more update/clue hopefully!!!! :slight_smile:

    I found this post http://wordpress.org/support/topic/233745 where andrea_r gave me a clue. I had deleted a couple of plugins and it seems that when the additional tags plugin is not present, the HTML code disappears. When the additional tages plugin is present, the code stays and everything works. Should mention this is in regards to the youtube video as it seems to have no effect on autoblog.

    I have posted the plugins I have installed above. I have and think have succeeded in only using plugins from this site and have not altered any code with the one exception of uncommented line 818.

    Hope this helps. :slight_smile:

  • James Farmer
    • CEO (of WPMU DEV, honest)

    @tim - not at the moment (we have a couple of major things on before coming back to this feature-wise) but I'd imagine before the end of the year... if there's enough clamour for it :slight_smile:

    @Leo I'm afraid you can only pull in as many posts as are in a feed... if you provide a feed with every post on it (i.e. the whole archive) then that should be able to be pulled in... I think.

  • Barry
    • DEV MAN’s Mascot

    @tim - I set my version of the plugin to show it's processing as it goes along, and all seemed to work without a hitch - it even imported your feed straight away on to my dev site (v. nice btw).

    So I'm not sure why it's not working on your server unless it's some sort of DNS issue that is stopping sites on your own server from accessing itself via the domain name.

    Are you on a vps or dedicated server? Or have ssh access to the server? What happens if you type nsloopkup trollans.ca on the server?

    Do you get the same result as when you type it anywhere else?

  • Barry
    • DEV MAN’s Mascot

    @leo - the first run on a feed will pull in all the posts in that feed. every run after that will only bring in the new entries.

    So if the feed author has limited it to the most recent 10 or 20 (etc) posts then that is all the reader will see.

  • tim@trollans.ca
    • Flash Drive

    Thank you.

    I am on shared hosting and they tell me it is vps. They are pretty good with me btw. ssh was disabled and I have enabled it now. Not quite sure how to access it though, but they tell me everything is pointing to where it should be. They seemed a little confused mind you when the pointing does not go to a subdirectory.

  • Leo
    • Flash Drive

    I installed the plugin and tested, and I saw that the autoblog is not pulling the media enclosures. Is there a way you guys can add that for next update, that would be an amazing feature for me. Also, when it pulls old feeds is there a way we can post the posts in the ORIGINAL date, there is an option for that but it doesnt work at least not the first time it pulls.

    Thanks

  • Gail Soriano
    • Design Lord, Child of Thor

    I too am having issues with the in-domain feed - https://premium.wpmudev.org/forums/topic/autoblog-sitewide-tags-tag-feed-oh-my#post-15262

    outside domain feeds work perfectly!

    but when I change it to in-domain feed this error shows on the Autoblog page:

    Catchable fatal error: Object of class stdClass could not be converted to string in /Library/WebServer/Documents/wp-includes/formatting.php on line 1128

    not sure how to attack that one - looked at formatting.php - seems to be something with stripslashes or striptslashes_deep but no dice as of yet

    thanks

    cmb

  • Barry
    • DEV MAN’s Mascot

    That error is a bit strange, as it is suggesting a WordPress file is generating the error.

    Regarding limiting to only domain feeds. I think it would limit the usefulness of it somewhat. I'm using it to pull in my Tweets from two accounts, and an SVN commit history to different categories for display on a site. None of which would be possible if I could only pull local feeds.

  • Gail Soriano
    • Design Lord, Child of Thor

    I hear you about the usefulness being limited - was thinking of my situation where that is the only thing I need but it does not seem to work.

    not sure if the error message is the same, but this is the same issue Tim is having - I have replaced formatting.php to no avail, commented out a number of lines from both autoblog.php and formatting.php but no dice.

    any other suggestions how to track down this issue? - puzzling that it only happens on internal feeds.

    I hate to impose - but if you had a moment can you test that feed above in your autoblog settings? was going to test at wordpress.com but not surprisingly autoblog isn't an option - just not sure how else to narrow the issue.

    thanks

    chris

  • Gail Soriano
    • Design Lord, Child of Thor

    After a few days of effort, and some trial and error, I have this working with internal feeds and with tag-feed feeds as well.

    The catchable error was eliminated by changing formatting.php in 1128 to

    function stripslashes_deep($value) {
    return $value;
    }

    which now upon saving autoblog settings the first time produces this error:

    Warning: mysql_real_escape_string() expects parameter 1 to be string, object given in /Library/WebServer/Documents/wp-includes/wp-db.php on line 492

    subsequent edits and saves to the same autoblog feed settings do not trigger this error

    and more importantly Autoblog now works with internal feeds and tag feed feeds

    to be honest, not sure what exactly what the repercussions of this modification is but any advice would be appreciated.

    thanks

    chris

  • jammastrj
    • New Recruit

    Hi - I'm new to WPMU but have been using WP for a long time, so the concepts aren't totally foreign to me, but I do have a problem, I think...

    When I try to setup Autoblog, I get a "Your feeds settings have been saved." message, but when I click on Auto Blog in Site Admin again, there are no entries and I have to start from scratch again.

    Not getting any error messages that I can see, so I need some help determining what's going on here.

    I apologize if this has already been answered - I looked around, but didn't find anything.

    Thanks
    -j

  • Gail Soriano
    • Design Lord, Child of Thor

    Hi Andrew - modifying formatting.php caused other issues in the site with working with certain characters(learned a lot from that effort) so went back to a clean install and autoblog is back to not recognizing internal feeds. Outside domain feeds work fine.

    Will the updated version take care of this? Am I the only one with this issue?

    thanks
    chris

  • Gail Soriano
    • Design Lord, Child of Thor

    Hi Barry - would this be the case if the RSS widget works? Seems the RSS widget would have the same issue if the server didn't recognize itself.

    At this page I have an in-domain feed working through the RSS widget but autoblog is also setup and you should see the same items as posts - pic of autoblog settings is attached.

    http://avoca37.org/jkirn/

    The only way I have made this work is in a previous post - editing formatting.php - I think there is something to do with stripslashes but not sure.

    Any other thoughts as to why this wouldn't work?

    thanks

    chris

  • tourbin
    • WPMU DEV Initiate

    I have installed according to instructions. At first I couldn't get any feeds to work (including the comment feed from this thread). But one time -- and I have no idea why -- an external feed did work and brought in posts from an external blog.

    I since deleted those posts, and now it doesn't work again. I added new feeds to auto blog with the same settings and nothing will work. Even the same external feed that once worked will not work anymore.

    Thanks for your help!

    Jay

  • svteg
    • Flash Drive

    Hi guys,

    I'm still dealing with the troubles I mentioned 3 weeks ago. If I want to add a new feed, the form starts loading, it opens a little and after 10 seconds it collapses. The autoblog is a great plugin for my site, but because of the problems I'm forced to use only one feed, a pitty!
    I installed the plugin on a fresh wpmu install, and then it works fine. So I hope for a new update very soon.

    Thanks,

  • James Farmer
    • CEO (of WPMU DEV, honest)

    So the problem is with an old install? But the new code works just fine?

    As we appear to have knocked off most issues for mist users with the latest release is there a chance you are still using the older one? Or that you might need to clear your autoblog dbase tables?

  • svteg
    • Flash Drive

    The problem is with an wpmu install that's on my server for 6 months, with many plugins in it. I wasn't aware of a new release, downloaded the 5 sept release just for sure tho the last weeks, for the test.
    Will clear up the autoblog tables..

    Thanks

  • Gail Soriano
    • Design Lord, Child of Thor

    James,

    I am still having the issues described in previous posts with internal feeds, as I think a few others are. I have a clean, new instal of 2.8.4a and It seems like some text is getting stripped out of internal feeds - editing formatting.php as indicated seems to fix but cause other issues.

    Any troubleshooting thoughts would be appreciated.

    thanks

    chris

  • Gail Soriano
    • Design Lord, Child of Thor

    Dedicating my work time this 3day weekend to fixing my issue with Autoblog - external feeds work fine - internal feeds not working at all with Autoblog as described in previous posts.

    Example of issue found in post from 1 week ago - http://avoca37.org/jkirn/ - built in RSS widget feed works fine as seen on the right - but posts should be autoblogged onto that page.

    Any advice, suggestions, thoughts would be appreciated.

    thanks

    chris

  • Gail Soriano
    • Design Lord, Child of Thor

    Hey Barry - yep - no problem there - anyone have an example of internal feeds working with autoblog? - would love to know that it works somewhere - that would give me some hope! next step is to disable all plugins on my test box to see if there is some conflict.

    thanks

    chris

  • Gail Soriano
    • Design Lord, Child of Thor

    After a few more hours yesterday I have decided to move on - went back to FeedWordPress which seems to do the job for now. Autoblog seems to be easier to setup and manage but I can't get it to work without core edits.

    Possibly the next version will work for me- looking forward to trying it out.

    thanks

    chris

  • svteg
    • Flash Drive

    Still not able to get this plugin to work, and got no answers on my last question:

    Can somebody please tell me how to totally remove the plugin so I can do a fresh install for the latest release. As mentioned in this topic a fresh install could solve my problems.

    My problem is the same as described in this topic: https://premium.wpmudev.org/forums/topic/need-auto-blog-help-cant-add-more But I can't add any new feed after the first feed. But also mentioned it multiple times before in this topic.

    The plugin is great, and I would love to use it for more than one feed. It's a great tool to provide the community fresh news.

    Please help :slight_smile:

  • erealestatemu
    • Flash Drive

    I'm not sure because I'm not the developer, but there are site options in the wp_sitemeta table called:

    autoblog_table
    autoblog_cron

    That the plugin uses. I assume if you delete those 2 records and remove the plug-in from the mu-plugins folder you should be back to normal.

    Of course each of the created posts have a original_source record in their meta (wp_xx_postmeta table for each blog). You could cycle through every blog and every post and remove it if you want, but I'm not sure this does any harm.

  • svteg
    • Flash Drive

    Thanks erealestatemu,

    I found the autoblog tables, and was able to do a fresh install. Unfortunately I still have the same problem. Internet explorer gives me this error:

    Line: 82
    Char: 2
    Error: Object doesn't support this property or method
    Code: 0
    URL: myurl.nl/wp-admin/wpmu-admin.php?page=autoblog_admin

    On a fresh wpmu install the plugin works perfect by the way. I hope this can be solved easily.

    Thanks in advance

  • erealestatemu
    • Flash Drive

    I have problems with IE too so I just use Chrome and it works fine.

    But, I just reached the plugin's limit. I have 30 feeds and they work but when I try to add another one it posts the form (as if I pushed the Save button) and my new record is lost. It seems all the Ajax trips over itself when there are more feeds than will fit on the page.

    I'd like to know the rationale of putting the entire feeds table into a single site option rather than making this a database app? Sorry, I'm a bit frustrated right now knowing I have to delete all my previous feeds in order to create new ones because this plug-in wasn't designed to handle a large number of feeds!

  • Barry
    • DEV MAN’s Mascot

    Hi
    Sorry for the delay in responding guys, they've got me super busy over here, so I shall try to answer as many as I can.

    Firstly, I'm afraid I don't have Internet explorer on tap, so it takes me a bit longer to track down those errors (though the IE error messages never were the most helpful :slight_smile: )

    The plugin uses / used site_options because I honestly didn't expect people to be adding 20 feeds, let alone 60, and I wanted it to be as simple as possible to install. Lesson learned, updated version will now have it's own table.

    The autoblog_cron option has the cron object that is merged with the system cron and handles the schedule. Deleting that option will reset the cron. autoblog_table holds the data, deleting that will clear everything out.

    My aim is to get an update out as soon as I can.

    Rgds
    Barry

  • erealestatemu
    • Flash Drive

    Hi Barry,

    Sorry I was a bit snippy in my last message but I don't do well at 4am. I finally had to hard code my own array and save it into the autoblog_table option to get it to work. At 2-3 feeds per blog for 32 blogs, that was a lot of work! Of course anytime I need to change it I have to modify autoblog.php. :slight_frown:

    I'm looking forward to the new data driven version. While you're there, could you please add a button to the form called "Process Now"? I added it to mine and it works great by simply calling the process_autoblog function.

    I'll try deleting the autoblog_cron and see if it fixes the scheduler. I have my feeds updating once a day so worst case I could just login and press the "Process Now" button every day, but it would be nice if I didn't have to.

    Thanks,
    Mark

  • svteg
    • Flash Drive

    Downloaded Chrome for just in case. But also in Chrome autoblog doesn't work so I'm forced to look at other ways.

    I tried the plugin feedwordpress, but it doesn't have the same flexibility as autoblog and besides that, the plugin removes the google ads.

    Someone a good suggestion?

  • RoneNeffect
    • Site Builder, Child of Zeus

    I noticed something weird today about the RSS Feed for my blog. While it does validate over at http://beta.feedvalidator.org/, when I enter the feed into my Google Reader, g-reader only spits out the very 1st blog post I made, even though I currently have 4 posts on my blog, 3 of which I made today.

    This makes me think that the something is "off" with the routing of urls in my WPMU, i.e. a permalink issue? I think this probably has an effect on both external and internal feeds when using autoblogger.

    Again, the very 1st post seems to work fine, but any post after that is no good. My next test will be to try and feed the main blog to one of my sub-blogs using autoblogger. Something tells me that result may emulate that Google reader snafu. I'll report back with results.

    My Feed: http://icraftsingles.com/blog/feed/
    My Blog: http://icraftsingles.com/blog/

  • RoneNeffect
    • Site Builder, Child of Zeus

    After examining my feed code, I noticed that the feed urls assigned to posts AFTER the very first blog post are appended with : /feed/ 0

    Whereas the feed url for the 1st blog post is /feed/ 1

    At least now I know I have a broken feed. It appears that my sub blogs are suffering from the same ailment. If I can't fix I will start a new thread.

    Maybe fixing my feeds will automagically fix my defunct autoblogger. However, I'm not seeing how that fix external feeds like twitter, unless autoblogger creates a internal feed from the external feed.

  • RoneNeffect
    • Site Builder, Child of Zeus

    Not a problem at all. I figure my rambling may help some people simply not do what I have tried, if nothing else. lol.

    Given the power of this plugin, a solution is well-worth the wait.

    Tell Barry to get better soon!

    Rone :o]

  • RoneNeffect
    • Site Builder, Child of Zeus

    measles...I mean "bump"

    Just came back to say that AutoBlog has AutoMagically started working for me just in time for the new year!

    The Story:

    Last week I decided that I needed BuddyPress so I installed it and was really impressed. Everything was working great except my blog page (with all my blog posts) was not accessible. You can read about how I fixed that here.

    Shortly after fixing my BuddyPress issue, posts from my Twitter account started showing up in the Posts section of my dashboard, as well as my blog. Dumbfounded, I deactivated any twitter plugins on my install and also revoked access connections on my actual Twitter account. The posts kept coming! After carefully examining the posts I noticed they were auto-categorized under "Twitter" and had the custom field "original_source" with a twitter status value.

    After the googling the "original_source" custom field...what comes up in search results? A listing for the AutoBlog plugin on WPMU Premium.

    I immediately go into my AutoBlog settings and realize that the Twitter feed I setup to post to my blog 2 weeks ago is obviously now working (along with auto-categorizing the posts under "Twitter"). Eureka! Voila! It Lives!

    So what made it start working. Remote Telepathic Will Power (RTWP) from Barry? Although I'm sure he has been trying it, I think it has to do with me changing the directory name of my WPMU install to fix the aforementioned BuddyPress issue I was having.

    When I originally installed my WPMU, I installed it in folder called /blog/. BuddyPress did not like this, so I changed the directory name to /social/, which made more sense anyway given the Buddypress addition. I think this allowed my install to finally start working with Autoblog. The proof? I didn't start receiving the "mystery" posts from Twitter until I renamed my install's directory to /social/.

    The moral of the story seems to be that you probably shouldn't name your WPMU install directory /blog/ or /blogs/ (if you are doing a subdirectory install). It seems to confuse a couple of plugins, like BuddyPress and Autoblog. If you try this, be sure this change is also made in my wp-config.php file and .htaccess file. Also double checked my database as well and had to tweak some WP Super Cache settings.

    Note that any existing member blogs may be adversely effected by this process (I only had test blogs on my install aside from the main blog, so I just deleted them and added new ones after renaming the directory). So this may not work as easily for people with non-test blogs.

    Cheers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.