Autoblog Twitter add-on

I am setting up Autoblog to connect Twitter feed to my website. I created the API in TW but I cannot validate it under Autoblog plugin, I entered consumer key, consumer secret and user screen name but when trying to validate it does not work.

  • James Morris

    Hello Israel Mejia

    I hope you are well today. I'll be following up with you regarding your chat.

    I took a look through the chat transcript and I checked your installed plugins. It appears you have Defender installed and I'm assuming you've applied the security tweaks.

    If you check inside wp-content/ you'll likely see a .htaccess file with the following contents:

    ## WP Defender - Protect PHP Executed ##
    <Files *.php>
    Order allow,deny
    Deny from all
    </Files>
    ## WP Defender - End ##

    This directive will block direct access to any PHP files in the subdirectories of wp-content/ which is good, except in your situation. I tested this out on my site and this directive blocked parsing of the built in script used to parse Twitter feeds. To allow access to that script, you need to update that directive to the following:

    ## WP Defender - Protect PHP Executed ##
    <Files *.php>
        deny from all
    </Files>
    <Files "twitter_json_rss.php">
        Order Allow,Deny
        Allow from all
    </Files>
    ## WP Defender - End ##

    Once you do this, Autoblog will be able to properly access the URL and fetch your Twitter feed.

    Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.