Autoblog was adding thousands of records each minute into the dbase

Hi,

I had to disable the autoblog plugin because it was adding thousands of records into the database each minute and was killing my websites...

Had to delete them manually with the command:
'DELETE FROM wp_options WHERE option_name LIKE "_transient%";# 106560 rows affected'

Tried to find the issue but can't tell what caused it....
Could someone please look into this?

I'm using the latest version of WP and the Autoblog plugin. It's on a MU environment.

Greetings,
Age

  • Jack Kitterhing
    • Code Norris

    Hi there @jongag1,

    Hope you're well today and sorry to hear of the issues your having here.

    Can you let me know how many feeds you had setup and the interval of when it checked for new posts in those feeds?

    Are you using any form of database caching? Are you using Multi-DB?

    Please advise.

    Thanks!

    Kind Regards
    Jack.

  • jongag1
    • The Crimson Coder

    Hi Jack,

    I do think to have find out the problem with help from somebody. The Nextgen Gallery was causing the options table to grow a lot for some reason. I believe because of that the Autoblog plugin got into some problems, and was adding many records into the options table as well.

    I've about 7 feeds (can't check right now because it's disabled), some of them run each 2 hours and some once a day.
    I'm not using any database caching or Multi-DB.

    The dbase was 2GB (!! aha, so that's why the websites wouldn't load....) and after cleaning the transient rules and optimizing 93MB... The websites show up perfect now. I will activate Autoblog again and keep NextGen Gallery disabled for some time to see what will happen.

    Thanks,
    Age

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.