Autoblog - WPMU DEV unable to edit post Permalink

I have installed Autoblog - WPMU DEV plugin in my site and i have imported some blogs using feed .

But when i published the blog post only some content and image is appearing in home page ,and once we click that its taking me to original site blog post .

And also i am unable to edit the post Permalink . The blog Permalink is linking to original blog post
where i am wrong . or auto blog will work in this way only ? (i have assumed that we copy all the content and images to my site using this plugin )

  • Predrag Dubajic
    • Support

    Hey Karthik,

    Hope you're doing well today :slight_smile:

    When importing posts via Autoblog it depends a lot on how the feed itself is configured and how does it allow its content to be pulled.

    I would like to have a closer look at your feed and settings if you could grant support access to your site.

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please respond in this thread once access is granted.

    Best regards,
    Predrag

  • Predrag Dubajic
    • Support

    Hi Karthik,

    Thanks for the access, I have inspected your feed and can see now what's going on.

    First with the easiest thing, your posts being set as draft, go to edit your feed and in there for "Default status for new posts" option set Published.

    Now for the permalink, the feed itself is configured in a way that adds original post URL, if you go to edit any post scroll down and you will see that original source field is added there, it looks like this:

    When you remove that field you will be able to edit permalink and it will now link to your own site.

    As for the content shown on your home page, this depends on your theme settings, unfortunately I'm not familiar with the theme you're using so it would be best getting in touch with your theme developers and see what can be done so that blog page shows full content.

    Best regards,
    Predrag

  • Karthik Balachandra
    • New Recruit

    Hello Predrag ...

    Thanks for your quick respones .

    1.i have set "Default status for new posts " to Draft beause i wanted to test before my blogs are going to live . once everything will works fine then i will move to published position .

    2. regarding Permalink, i am sorry to say this .i went to post and in edit option i am unable to get option to remove the "orginal_field"

    can you help to get those option . where it exactly come ?

  • Dimitris
    • Support Star

    Hey there Karthik Balachandra,

    hope you're doing good and don't mind chiming in!

    I just went ahead and activated the Custom Fields section for you

    I then went ahead and clicked on "delete" of the "original_source" of a drafted post ("10 Healthy Snack Recipes For The New Year"). Then I clicked on "publish" button and after page refreshing, the post URL was "reverted" to use your domain path. :wink:

    Warm regards,
    Dimitris

    PS. The post I used for my test is already marked as "draft" again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.