AUTOBLOGS – Can't import a feed

Hello,

I tried to set up the autoblog plugin but with the first feed I want to import, I get stuck because of the feed isn’t validate.

I tried to enable some plugins of the autoblog plugin to skip this king of error but nothing.

The feed I try to import comes from another WordPress.

All the plugins are up to date, the WordPress core too.

I don’t want to use another plugin than yours! But this has to be able to import a large number of feeds (this is the website of a large numbers of associations).

Thank you for your help.

Have a nice day !

  • Predrag Dubajic
    • Support

    Hey Alexandre,

    Hope you’re doing well today :slight_smile:

    Could you share your feed URL so we can test it out on our end end see if the issue is specific to your site or the feed itself?

    If you don’t want to share the URL publicly you can grant us support access to your site and then paste the URL in text field there.

    To enable support access you can follow this guide here:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Alex,

    Thanks for granting access, I had a look at your feed and after testing it on my installation and couple of RSS validators I’m afraid that the issue is with the RSS feed itself as it doesn’t validate anywhere so Autoblog is unable to process it.

    The feed needs to be fixed first and the Autoblog should be able to process it without any issues after that.

    Have you tried fixing it with plugins like this one: https://wordpress.org/plugins/fix-my-feed-rss-repair/

    Best regards,

    Predrag

  • Alexandre
    • New Recruit

    Hi Predrag,

    Thanks for your answer.

    I’m sorry but your solution is not the solution. I’ll have to get a hundred of feeds from a hundred of sites and all of them are independant and not owned by the same persons. So, tell to a hundred persons to install a plugin (by the way, the plugin you tell me about didn’t fix my feed) is not a solution.

    I try to activate the WPMU plugin “Allow Force Feed” and check “enable force feed” on the feed but that doesn’t change, nothing is imported. I don’t understand the usage of this if you can’t set to force the feed to be imported, I don’t care if there is an error, I’ll correct the text after but I have to have the posts created.

    So, could you try this feed : http://carrefourlaiqueaubenas.fr/index.php/feed/

    on one of your testing site with this plugin and tell me if it proceed please?

    Thank you!

    Best regards,

    Alex

  • Dimitris
    • Support Star

    Hey there Alexandre,

    hope you’re doing good today and don’t mind me jumping in here! :slight_smile:

    I tested the second feed URL you’ve shared, but I wasn’t able to surpass the same error, despite any settings that I’ve tried. I played with “Allow Force Feed” and “Disable Sanitization” add-ons with no avail! :unamused:

    I keep getting the following error message after trying to process the feed:

    This XML document is invalid, likely due to invalid characters. XML error: Invalid character at line 252, column 25

    I even switched WP language to french, but had no result. I can still import french characters from another feed url though (http://www.gouvernement.fr/rss.xml).

    I think that unfortunately I have to agree with my colleague Predrag here, the feed URL can’t be imported as is.

    Warm regards,

    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.