Automate can't detect outdated plugins

There are 3 outdated plugins, Hummingbird, Snapshot and one plugin from wp.org. Automate shows in log:
Available plugin updates: 0 ()

When attempting a backup Automate returns this message:
"Backup start error: firewall_block - It appears that you have security precautions in place that are blocking remote updates.
Often these are in a security plugin, firewall, or .htaccess file. To enable remote updates you might need to whitelist our IP ."

Automate IP is not blacklisted on a server level. The .htaccss doesn't have any defined rules that can block Automate. The only security plugin is Defender when deactivated, the issue still persists