Automate not updating plugins on my site

I had a couple of plugins that needed to be updated, and while Automate was enabled, the updates shold have been done automatically, but it's not the case. Automate last run was on April, any ideas what might cause this ?

  • Dimitris

    Hello Bamboo,

    hope you're doing good today! :slight_smile:

    I reviewed our Automate logs about the reported domain and I can see the followings:

    last_report: 2018-04-23 17:24:45
    next_run: 2018-06-24 16:01:47
    
    ----- Running automate: 2018-06-17 16:02:46
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    
    ----- Running automate: 2018-06-10 16:43:09
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    
    ----- Running automate: 2018-06-03 16:59:14
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    
    ----- Running automate: 2018-05-27 16:52:46
    Available plugin updates: 0 ()
    Available theme updates: 0 ()

    So it seems that the schedule is set to check for updates once a week and it was doing so, but it wasn't getting any pending updates at all...
    Could you please set this again to daily (just select all days), spare some hours until the schedule should trigger again and let us know in your next reply when this is done?

    Additionally, can you create a new testing WP site in the same server, install our WPMUDEV Dashboard plugin and any previous version of a plugin from wp.org, activate Automate daily and see if that is getting updated?

    Warm regards,
    Dimitris

  • Dimitris

    Hello there Bamboo

    I checked our logs again and I'm still getting strange results.

    schedules (GMT): monday, tuesday, wednesday, thursday, friday, saturday, sunday at 5:00pm
    
    ----- Running automate: 2018-07-08 17:48:02   -----
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    Execution time: 0.0049350261688232s
    Log time: 2018-07-01 17:47:07
    
    ----- Running automate: 2018-07-01 17:47:03   -----
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    Execution time: 0.0037519931793213s
    Log time: 2018-06-24 18:11:27
    
    ----- Running automate: 2018-06-24 18:10:43   -----
    Available plugin updates: 0 ()
    Available theme updates: 0 ()
    Execution time: 0.0048789978027344s
    Log time: 2018-06-23 17:24:33
    
    ----- Running automate: 2018-06-23 17:23:01   -----
    Available plugin updates: 2 (912164, 1081721)
    Available theme updates: 0 ()
    Generating an initial screenshot
    Screenshot error: Endpoint request timed out
    Updating: 912164
    Update success
    Updated: 0 - array (
      0 => 'Downloading update from https://premium.wpmudev.org/api/dashboard/v2/download/912164/e*********************************d9d2e6…',
      1 => 'Unpacking the update…',
      2 => 'Installing the latest version…',
      3 => 'Removing the old version of the plugin…',
      4 => 'Plugin updated successfully.',
    )
    Updating: 1081721
    Update error: unexpected_response - We got an unexpected response from your website: "504 Gateway Timeout"
    Uptime ping shows site as up
    ----- Sending report: (2018-06-23 17:24:32) -----
    Email sent successfully
    Sending alert report...
    ----- Sending alert: (2018-06-23 17:24:33) -----
    Email sent successfully
    Execution time: 91.511051893234s

    I've already pinged our developers about it, me or another colleague of mine will keep you posted here as soon as possible.
    Meanwhile, could you please share your WPMUDEV credentials, so we can review your Hub settings? As this is public forum, you must send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WPMUDEV login (username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris

  • Dimitris

    Hello Bamboo

    Our sysadmins triggered a manual run yesterday, and it changed next run to match your schedule settings. I can now see that it caught the latest SmartCrawl update and successfully updated it.
    Logs:

    ----- Running automate: 2018-07-13 18:01:11 -----
    Available plugin updates: 1 (167)
    Available theme updates: 0 ()
    Generating an initial screenshot
    Screenshot error: Endpoint request timed out
    Updating: 167
    Update success
    Updated: 0 - array (
      0 => 'Downloading update from https://premium.wpmudev.org/api/dashboard/v2/download/167/e*********************************d9d2e6…',
      1 => 'Unpacking the update…',
      2 => 'Installing the latest version…',
      3 => 'Removing the old version of the plugin…',
      4 => 'Plugin updated successfully.',
    )
    Uptime ping shows site as up
    ----- Sending report: (2018-07-13 18:01:57) -----
    Email sent successfully
    Execution time: 46.45409488678s

    What I noticed though, is the date in above screenshot. Even though update happened today (14/7), there's a June 24, 2018 which doesn't make much sense.

    I've already informed our sysadmins and developers about it. Meanwhile, I see in our end

    next_run: 2018-07-14 17:17:45
    last_run: 2018-07-13 18:01:55

    so this should be working good now. Feel free to install an outdated plugin without activating it, just for testing. For example: https://downloads.wordpress.org/plugin/hello-dolly.1.5.zip

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.